summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2021-05-21 21:41:28 +0300
committerPatrice Clement <monsieurp@gentoo.org>2021-06-12 12:16:10 +0200
commit56e8ec8bf3f2a630901fdfdda2c9376d0c5256b4 (patch)
tree765cf09bcba637d4023f3c86c545c7302733bded /app-editors
parentapp-misc/pax-utils: allow python-3.10 (diff)
downloadgentoo-56e8ec8bf3f2a630901fdfdda2c9376d0c5256b4.tar.gz
gentoo-56e8ec8bf3f2a630901fdfdda2c9376d0c5256b4.tar.bz2
gentoo-56e8ec8bf3f2a630901fdfdda2c9376d0c5256b4.zip
app-editors/vim: add ipv6 USE flag support.
Closes: https://bugs.gentoo.org/790446 Closes: https://github.com/gentoo/gentoo/pull/20911 Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/metadata.xml1
-rw-r--r--app-editors/vim/vim-8.2.0814-r100.ebuild8
2 files changed, 8 insertions, 1 deletions
diff --git a/app-editors/vim/metadata.xml b/app-editors/vim/metadata.xml
index acc712bdb241..bc092f380c09 100644
--- a/app-editors/vim/metadata.xml
+++ b/app-editors/vim/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="cscope">Enable cscope interface</flag>
+ <flag name="ipv6">Enable IPv6 support in channel</flag>
<flag name="racket">Enable support for Scheme using <pkg>dev-scheme/racket</pkg></flag>
<flag name="terminal">Enable terminal emulation support</flag>
<flag name="vim-pager">Install vimpager and vimmanpager links</flag>
diff --git a/app-editors/vim/vim-8.2.0814-r100.ebuild b/app-editors/vim/vim-8.2.0814-r100.ebuild
index 085e62c4a3f7..c6cf07318e82 100644
--- a/app-editors/vim/vim-8.2.0814-r100.ebuild
+++ b/app-editors/vim/vim-8.2.0814-r100.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="X acl cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
+IUSE="X acl cscope debug gpm lua ipv6 minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -228,6 +228,12 @@ src_configure() {
)
fi
+ if ! use ipv6; then
+ myconf+=(
+ vim_cv_ipv6_networking=no
+ )
+ fi
+
# don't test USE=X here ... see bug #19115
# but need to provide a way to link against X ... see bug #20093
myconf+=(