summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 14:22:43 +0100
committerSam James <sam@gentoo.org>2022-10-04 14:26:20 +0100
commit5fe498a50be9bdf2f8f1ca33cf31047be7560081 (patch)
tree1bc1654f931fec4e3a7c8eac59622c8c4817d621 /app-editors
parentapp-editors/vim-core: drop 8.2.4586-r1, 8.2.5066-r3 (diff)
downloadgentoo-5fe498a50be9bdf2f8f1ca33cf31047be7560081.tar.gz
gentoo-5fe498a50be9bdf2f8f1ca33cf31047be7560081.tar.bz2
gentoo-5fe498a50be9bdf2f8f1ca33cf31047be7560081.zip
app-editors/vim-core: fix IndirectInherits, sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 17a02fa52a3c..f55b9057046f 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -147,6 +147,14 @@ src_configure() {
# Keep Gentoo Prefix env contained within the EPREFIX
use prefix && myconf+=( --without-local-dir )
+ if tc-is-cross-compiler ; then
+ export vim_cv_getcwd_broken=no \
+ vim_cv_memmove_handles_overlap=yes \
+ vim_cv_stat_ignores_slash=yes \
+ vim_cv_terminfo=yes \
+ vim_cv_toupper_broken=no
+ fi
+
econf "${myconf[@]}"
}