summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-03 01:41:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-03 01:42:45 +0200
commit620bc39ddfd82029bbeb0a4c0c0a9ddc97c0936b (patch)
treeae973c07d516c9e25d4cba405fc5e59be10ce429 /app-editors
parentdev-lang/python: Bump to 3.8.9 (diff)
downloadgentoo-620bc39ddfd82029bbeb0a4c0c0a9ddc97c0936b.tar.gz
gentoo-620bc39ddfd82029bbeb0a4c0c0a9ddc97c0936b.tar.bz2
gentoo-620bc39ddfd82029bbeb0a4c0c0a9ddc97c0936b.zip
app-editors/mousepad: Bump to 0.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.5.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index ef24ac0c5a1a..60731d356d48 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,2 +1,3 @@
DIST mousepad-0.5.2.tar.bz2 850592 BLAKE2B a30185f7a9c276eb5744db4664cdc9ad41520ec12018118f5ddfc2d39a5a5d6545d90222660d585c5b570c9e5a32c921edf2d727adcfad6addacdaa412d094e4 SHA512 03302b95f411240d19631b48fe462e47b7d6fa9cc0df07b9de2e56f1f402a9058ab423353ab8b3530ad14889e62299c7a1bed020349cca059d13566c6b8db8b8
DIST mousepad-0.5.3.tar.bz2 848169 BLAKE2B c5001d5a1f3c8ef820fdf2297679b8c7acae7cb08ed134529b7b1e0861e8d9b36c9495b6a207371c9e6a0f59a3f7bd41adaa678250d96ab7112427d5cfc2aa0d SHA512 596d85a9b7caa1616bd5adc2bb4f7ddbdf47d9e4a049f100581ecba9c61db5243f45d3dd8217ecaed1803c73c2221a396817790efe3898c487c12c8ce8d328c6
+DIST mousepad-0.5.4.tar.bz2 855416 BLAKE2B a998b2faabae1ad505da3a8fb560c731e6f5002801cdc3a4edcd515d5d75210ae509261644070e1951629271bd5956aee1e196c35c6b7e9c3ab782cd06b35ac6 SHA512 52d1d9b235b13a651ee7e6e1633074c7829c27e880033637eacdd7cd63f246d1f47d0cd2c981cf2a7eb96dbb7119204a685f00a60968e4478d5057bce8500370
diff --git a/app-editors/mousepad/mousepad-0.5.4.ebuild b/app-editors/mousepad/mousepad-0.5.4.ebuild
new file mode 100644
index 000000000000..bcb567c7aa26
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.5.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.52
+ >=xfce-base/xfconf-4.12:=
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}