summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-05-01 17:52:41 +0200
committerUlrich Müller <ulm@gentoo.org>2023-05-01 17:52:41 +0200
commit70f7c63cb6eb56651e5b45f1b009429bc414e533 (patch)
tree3eeda20136afd7ecae03989441c5651686019e99 /app-editors
parentdev-db/postgis: Add blocker for dev-cpp/abseil-cpp (diff)
downloadgentoo-70f7c63cb6eb56651e5b45f1b009429bc414e533.tar.gz
gentoo-70f7c63cb6eb56651e5b45f1b009429bc414e533.tar.bz2
gentoo-70f7c63cb6eb56651e5b45f1b009429bc414e533.zip
app-editors/mg: add 20230501
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/Manifest1
-rw-r--r--app-editors/mg/mg-20230501.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index a7f275c30a12..81a5e843295c 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1,3 +1,4 @@
DIST mg-20220614.tar.gz 157904 BLAKE2B 88141274b379c6117158f85d91d0d643709437f0292fe2f82569c33d85694b39f957e279e262839ef0ba2a7e81e8a9ad6512c621e68f42b0929805028898637a SHA512 bed455cda856e54fae28592ac0a520841d5d542880a7405dadf702d7407ac33ae7fb7b63880805a7e166e0e0a87c76b9fca1700c444f1b999a5af66732c69b65
DIST mg-20221112.tar.gz 158666 BLAKE2B b32f957a4491901c0926668fb74df450de679d95d1ca2352f7eab0be0e6fa06b703551c3f9be6bed80918daec9096fbbc8f774f3e0255c668a8ebe0c0bcf99a6 SHA512 7d2d08d7015357ceece4eeaf876a3c0a8e27554aed224854efb831c23c78157a104df724b9ac3ad9f74efce6b066c94616fadf8979906f453469a03bc5d005b8
DIST mg-20230406.tar.gz 157992 BLAKE2B d9e8a4abfa869cc901e246cf42d6cd1eabc15cd5c3cff678342d78f9beda1f84192430a97cc362bc0b0ddc072d04d30087b85dbd2de071dd11562220d073781c SHA512 0d1ad46899c7afc4ce6634f0274286400d8a6bd8a7e28df970e1b6470d10520e1a74acb6059f3774a9ab9f6fd8e9ed7ddacf1cb70134538348e10f58a354ea4f
+DIST mg-20230501.tar.gz 158315 BLAKE2B b8f68d4cd80a1735ce171bf653281104f7c8b5510a45088a136955d6649e969285914d27d2ee5bd4400643507943576e3c42959949aebb81bc1bb2f99a8e660e SHA512 db7b9815a01dc9fb1ff92741748d24d558c329135e591c24450d0a3bc10e38a992ef346dd744854864538f330a018415df539d06543570a3566dbabc6c88a8fd
diff --git a/app-editors/mg/mg-20230501.ebuild b/app-editors/mg/mg-20230501.ebuild
new file mode 100644
index 000000000000..3385a89393fd
--- /dev/null
+++ b/app-editors/mg/mg-20230501.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://github.com/hboetes/mg"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="livecd"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/libbsd-0.7.0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}