summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-06-09 20:10:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-06-09 20:14:30 +0300
commit7441a98f54f309aaa72917c6479f95d66e064bfd (patch)
tree17a6cc48b090cd026d7e69bf883d46d5cb149b84 /app-editors
parentapp-crypt/acme-sh: drop mask (diff)
downloadgentoo-7441a98f54f309aaa72917c6479f95d66e064bfd.tar.gz
gentoo-7441a98f54f309aaa72917c6479f95d66e064bfd.tar.bz2
gentoo-7441a98f54f309aaa72917c6479f95d66e064bfd.zip
app-editors/vscode: add 1.79.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.79.0.ebuild122
2 files changed, 125 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 63401dc2162c..e758ff4eb6ac 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -1,3 +1,6 @@
DIST vscode-1.78.2-amd64.tar.gz 134674196 BLAKE2B 314ab07185d91bf20d4016b327496924c111c7b7ef6e2775c7abbb5a497a35ad09e5a7176691849ab36e28f4d291e6a4e2cfa4024c00fc45e5b13514997d71c2 SHA512 a5919a7f04257c529a7c0a0147e2f8d18181c90a64198d822957d74e5bc8e5d3c60f7732a4f3c456f0036907d82688d51435dbe26aa25264bd1014fe97da4a1b
DIST vscode-1.78.2-arm.tar.gz 119250112 BLAKE2B 3a0bf7ea25b85202a3d0be196721e2aacf79dc8c6bcf5ae97d37d04c82ca782b3641435997b029170618f4cab31c59978faf70a5bf89ac2e834e7743e1822063 SHA512 ffeff708c553903c10c9ce833e28286144e1407e59298a05f00ce75912605061914268fff34f74e5e0e6a21989191fa9c5e757c271a784ec0ccfa2db02567679
DIST vscode-1.78.2-arm64.tar.gz 130761570 BLAKE2B 6fbd079ca89f49419e53e1daf108e6508036a654395bbdc1ce61bed4c9fbb0425738ba39f8d7682b889f80f5c08fdff947f819c36e932bf652f1441182981e07 SHA512 877ce23498c68f2c3eadae5eafc83cecedefa0d290efb2578f3ab0faa6c9aa8d2fe22e9e4f33afbe9a95cfb12b994411de3303b902da73af5c33be43345d52e7
+DIST vscode-1.79.0-amd64.tar.gz 134771216 BLAKE2B eff3918fdc4c48cb9b0dd0ba09f5cf10c707c3fe491905a4150cfd634722d66e49a13c3d08828c3eafcc8b507356308d829b32e5c57313194157c27b9d895e6a SHA512 586898b17af29bf218af765cf7a8c3aefd7b73d181c9bafa3a98fc8f2f74d14c6c132179542b1b5ffa364b153bb8c5d71150d0ef40266913685640c2640c7209
+DIST vscode-1.79.0-arm.tar.gz 119314354 BLAKE2B 23ffd7c9202e5491e41c5b99a707807ca3cd06ba5323f5c67859344c95dc19848ec9daa83bc97f2afa585cd93a4cf62da0608a3cc4788d9e4b71a468a1fad6c3 SHA512 9eecbeaf34b4248915e4c0f922c7033c140cb4944e73775c116bd1e03c8cd3feb2f702e6d089df057b307637e2b4065a06e377b156d22ea92dee1741c846934f
+DIST vscode-1.79.0-arm64.tar.gz 130967654 BLAKE2B fe5a484b12ad1ef6c9cccbe95cab149a0caf9fe6d5f2b5f6354dbf154346f5cfb6d6c4da839149dfff2194b43ac72639a2e5df457aedcd2bcf96cd8fff9515e9 SHA512 b2541ea525ae82b8468b6b41990f73cb881461f352691959402d7927423a1ec215a43db7aac7f9b3ae83e6507cdf5c7645431fc08872dde8df7d6b4ce47c20f3
diff --git a/app-editors/vscode/vscode-1.79.0.ebuild b/app-editors/vscode/vscode-1.79.0.ebuild
new file mode 100644
index 000000000000..0362e867fb48
--- /dev/null
+++ b/app-editors/vscode/vscode-1.79.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscode/chrome_crashpad_handler
+ /opt/vscode/chrome-sandbox
+ /opt/vscode/code
+ /opt/vscode/libEGL.so
+ /opt/vscode/libffmpeg.so
+ /opt/vscode/libGLESv2.so
+ /opt/vscode/libvk_swiftshader.so
+ /opt/vscode/libvulkan.so*
+ /opt/vscode/resources/app/extensions/*
+ /opt/vscode/resources/app/node_modules.asar.unpacked/*
+ /opt/vscode/swiftshader/libEGL.so
+ /opt/vscode/swiftshader/libGLESv2.so
+"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+ dosym -r "/opt/${PN}/bin/code-tunnel" "usr/bin/code-tunnel"
+ domenu "${FILESDIR}/vscode.desktop"
+ domenu "${FILESDIR}/vscode-url-handler.desktop"
+ domenu "${FILESDIR}/vscode-wayland.desktop"
+ domenu "${FILESDIR}/vscode-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}