summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-06-16 11:38:13 +0200
committerUlrich Müller <ulm@gentoo.org>2022-06-16 11:39:20 +0200
commit969ff44afad73659f8f207c5bb65020318fac872 (patch)
treef9d28af397af2ccdf95d318b9220a04490bb7c9f /app-editors
parentdev-python/pyglet: Stabilize 1.5.26 x86, #852419 (diff)
downloadgentoo-969ff44afad73659f8f207c5bb65020318fac872.tar.gz
gentoo-969ff44afad73659f8f207c5bb65020318fac872.tar.bz2
gentoo-969ff44afad73659f8f207c5bb65020318fac872.zip
app-editors/mg: add 20220614
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/Manifest1
-rw-r--r--app-editors/mg/mg-20220614.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index 58edce8fcd27..c98c6990580a 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1,2 +1,3 @@
DIST mg-20210609.tar.gz 156850 BLAKE2B ed8061aa808a8570f24198fb32fa3d24d66decdd07dab871502456d734a8d7867f384122361294bda0155bc3fecea80983fd41c00a2ffe02d00e380bf94e2f43 SHA512 a17b470e5e192c1f62700c7b78b15c9403b25528a7d6603fda0b6e618196150329fe4889cedfc8dbf621053d45b78294ed5c2766604aaa4c3ddbaec545693043
DIST mg-20220212.tar.gz 157828 BLAKE2B e3219efffef9c4da05965a0ed7a0f0bfdf5c34d607d25102a4d2ee9de6f9b9fd2da59050c6e56d1712875b2d129408200dde4c7305ffb2208c11b5d722b87270 SHA512 093736521e4bcaeff049594793474b9710e4cfe6db151032dc4413614566afce80db5b794dcf10082020dbb73f25742a0c7d49f45b6b4d2caa6865b20a9e574b
+DIST mg-20220614.tar.gz 157904 BLAKE2B 88141274b379c6117158f85d91d0d643709437f0292fe2f82569c33d85694b39f957e279e262839ef0ba2a7e81e8a9ad6512c621e68f42b0929805028898637a SHA512 bed455cda856e54fae28592ac0a520841d5d542880a7405dadf702d7407ac33ae7fb7b63880805a7e166e0e0a87c76b9fca1700c444f1b999a5af66732c69b65
diff --git a/app-editors/mg/mg-20220614.ebuild b/app-editors/mg/mg-20220614.ebuild
new file mode 100644
index 000000000000..7d529ea79741
--- /dev/null
+++ b/app-editors/mg/mg-20220614.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://github.com/hboetes/mg"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="livecd"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/libbsd-0.7.0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}