summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 14:26:11 +0100
committerSam James <sam@gentoo.org>2022-10-04 14:26:50 +0100
commita41718ec4c26b8aac76dd79e71709d5585807253 (patch)
treefcd25ac0476ff0fbfdd1e81c3460145c268586e3 /app-editors
parentapp-editors/gvim: bump to 9.0.399 (diff)
downloadgentoo-a41718ec4c26b8aac76dd79e71709d5585807253.tar.gz
gentoo-a41718ec4c26b8aac76dd79e71709d5585807253.tar.bz2
gentoo-a41718ec4c26b8aac76dd79e71709d5585807253.zip
app-editors/gvim: fix Lua 5.1 deprecated API implicit. func. decls
Closes: https://bugs.gentoo.org/874690 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-9.0.0099.ebuild4
-rw-r--r--app-editors/gvim/gvim-9.0.0399.ebuild4
-rw-r--r--app-editors/gvim/gvim-9999.ebuild4
3 files changed, 12 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-9.0.0099.ebuild b/app-editors/gvim/gvim-9.0.0099.ebuild
index 94b5164b1a3a..66d81a92fa7a 100644
--- a/app-editors/gvim/gvim-9.0.0099.ebuild
+++ b/app-editors/gvim/gvim-9.0.0099.ebuild
@@ -209,6 +209,10 @@ src_configure() {
)
if use lua; then
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#874690)
+ use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
+
myconf+=(
--enable-luainterp
$(use_with lua_single_target_luajit luajit)
diff --git a/app-editors/gvim/gvim-9.0.0399.ebuild b/app-editors/gvim/gvim-9.0.0399.ebuild
index 27e25b32be34..41d899a1c67d 100644
--- a/app-editors/gvim/gvim-9.0.0399.ebuild
+++ b/app-editors/gvim/gvim-9.0.0399.ebuild
@@ -210,6 +210,10 @@ src_configure() {
)
if use lua; then
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#874690)
+ use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
+
myconf+=(
--enable-luainterp
$(use_with lua_single_target_luajit luajit)
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index fe0d1d0e564f..66490dcc956e 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -209,6 +209,10 @@ src_configure() {
)
if use lua; then
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#874690)
+ use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
+
myconf+=(
--enable-luainterp
$(use_with lua_single_target_luajit luajit)