summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2016-11-07 20:57:50 -0500
committerPacho Ramos <pacho@gentoo.org>2016-11-09 10:01:16 +0100
commitc0a9b528a16185b57c48cfc46519d06b54482dfa (patch)
tree405528d7c1997b32db141b6fc4e99f4362360fa7 /app-editors
parentnet-libs/liboauth: Specify proper openssl slot (diff)
downloadgentoo-c0a9b528a16185b57c48cfc46519d06b54482dfa.tar.gz
gentoo-c0a9b528a16185b57c48cfc46519d06b54482dfa.tar.bz2
gentoo-c0a9b528a16185b57c48cfc46519d06b54482dfa.zip
app-editors/nvi: don't force <=sys-libs/db-4.8
Also, remove unecessary "! use unicode" tests, and add EPREFIX to the message catalog path. Gentoo-Bug: https://bugs.gentoo.org/599136 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nvi/nvi-1.81.6-r7.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-editors/nvi/nvi-1.81.6-r7.ebuild b/app-editors/nvi/nvi-1.81.6-r7.ebuild
new file mode 100644
index 000000000000..33465b67480c
--- /dev/null
+++ b/app-editors/nvi/nvi-1.81.6-r7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools db-use flag-o-matic
+
+DESCRIPTION="Vi clone"
+HOMEPAGE="https://sites.google.com/a/bostic.com/keithbostic/vi"
+SRC_URI="http://garage.linux.student.kuleuven.be/~skimo/nvi/devel/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl tcl unicode"
+
+CDEPEND=">=sys-libs/db-4.2.52_p5:=
+ >=sys-libs/ncurses-5.6-r2:=
+ perl? ( dev-lang/perl )
+ tcl? ( >=dev-lang/tcl-8.5:0 )"
+
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="${CDEPEND}
+ app-eselect/eselect-vi"
+
+REQUIRED_USE="tcl? ( !unicode )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-strlen-macro-renaming.patch
+ "${FILESDIR}"/${P}-db44.patch
+ "${FILESDIR}"/${P}-db.patch
+ "${FILESDIR}"/${P}-perl-as-needed.patch
+ "${FILESDIR}"/${P}-perl-shortnames.patch
+ "${FILESDIR}"/${P}-ac_config_header.patch
+ "${FILESDIR}"/${P}-use_pkgconfig_for_ncurses.patch
+ "${FILESDIR}"/${P}-printf-types.patch
+ )
+
+src_prepare() {
+ default
+
+ cd dist || die
+ chmod +x findconfig || die
+
+ mv configure.{in,ac} || die
+ sed -i -e "s@-ldb@-l$(db_libname)@" configure.ac || die
+ sed -i -e "s@^install-\(.*\)-local:@install-\1-hook:@" Makefile.am || die
+ eautoreconf -Im4
+}
+
+src_configure() {
+ local myconf
+
+ use perl && myconf="${myconf} --enable-perlinterp"
+ use unicode && myconf="${myconf} --enable-widechar"
+ use tcl && myconf="${myconf} --enable-tclinterp"
+
+ append-cppflags "-D_PATH_MSGCAT=\"\\\"${EPREFIX%/}/usr/share/vi/catalog/\\\"\""
+ append-cppflags -I"$(db_includedir)"
+
+ pushd dist 2>/dev/null || die
+ econf \
+ --program-prefix=n \
+ ${myconf}
+ popd 2>/dev/null || die
+}
+
+src_compile() {
+ emake -C dist
+}
+
+src_install() {
+ emake -C dist DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/vi symlink"
+ eselect vi update --if-unset
+}