summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-28 18:52:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-28 19:20:42 +0100
commitc740dae40a35352abae963d07f1a9d0b563eedd8 (patch)
tree72f150dd26d134593b9ffeb846c2bd9ec6db842c /app-editors
parentdev-libs/libbson: Switch to cmake.eclass (diff)
downloadgentoo-c740dae40a35352abae963d07f1a9d0b563eedd8.tar.gz
gentoo-c740dae40a35352abae963d07f1a9d0b563eedd8.tar.bz2
gentoo-c740dae40a35352abae963d07f1a9d0b563eedd8.zip
app-editors/mousepad: Bump to 0.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.5.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 5cada7c40579..ef24ac0c5a1a 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1 +1,2 @@
DIST mousepad-0.5.2.tar.bz2 850592 BLAKE2B a30185f7a9c276eb5744db4664cdc9ad41520ec12018118f5ddfc2d39a5a5d6545d90222660d585c5b570c9e5a32c921edf2d727adcfad6addacdaa412d094e4 SHA512 03302b95f411240d19631b48fe462e47b7d6fa9cc0df07b9de2e56f1f402a9058ab423353ab8b3530ad14889e62299c7a1bed020349cca059d13566c6b8db8b8
+DIST mousepad-0.5.3.tar.bz2 848169 BLAKE2B c5001d5a1f3c8ef820fdf2297679b8c7acae7cb08ed134529b7b1e0861e8d9b36c9495b6a207371c9e6a0f59a3f7bd41adaa678250d96ab7112427d5cfc2aa0d SHA512 596d85a9b7caa1616bd5adc2bb4f7ddbdf47d9e4a049f100581ecba9c61db5243f45d3dd8217ecaed1803c73c2221a396817790efe3898c487c12c8ce8d328c6
diff --git a/app-editors/mousepad/mousepad-0.5.3.ebuild b/app-editors/mousepad/mousepad-0.5.3.ebuild
new file mode 100644
index 000000000000..727e1bf86564
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.5.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.52
+ >=xfce-base/xfconf-4.12:=
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-3.24:3.0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}