summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-23 08:40:20 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-23 09:30:38 +0200
commitc91548549b68df52436f844853e3f9ffc4f4a328 (patch)
tree31631e1209aadcab519effc21d1bb0dbb9699da1 /app-editors
parentapp-admin/awscli: add 1.27.36 (diff)
downloadgentoo-c91548549b68df52436f844853e3f9ffc4f4a328.tar.gz
gentoo-c91548549b68df52436f844853e3f9ffc4f4a328.tar.bz2
gentoo-c91548549b68df52436f844853e3f9ffc4f4a328.zip
app-editors/vscodium: add 1.74.2.22355
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.74.2.22355.ebuild121
2 files changed, 124 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index eb96fdde87e9..6071675b4bd1 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.74.0.22342-arm64.tar.gz 114462026 BLAKE2B 56f965056b826868e3c89c
DIST vscodium-1.74.1.22349-amd64.tar.gz 121393633 BLAKE2B e30b7edd966e56f79742bd045e75d02b76d886ea3cc450121e2ad625fc9a2296d78fb652e8a796fe04def3d5a7a56020e658d6f8401a9546366838af2ea26cb5 SHA512 0f05d3e17603cbdd072210f6d725fc3f9b5a03bcd01b0962f5ada48486e5d1caeb222b5c25ba9a5353f2455a282f61ed4af1660b23f7aec5f994c80187682145
DIST vscodium-1.74.1.22349-arm.tar.gz 103433677 BLAKE2B 820b1363f5814549c13f2c15edbd14ac55be7a78f0357ffc3655f3e1b641977da344419865b116e72da1d26be0754e48ef1b8145d9e9c28ffc83f2ce7fef5326 SHA512 69ccef8a618aa9f56ba24720217e7b33fcf42aa8c6ce879c938b1e0a5b7887c9472083ff92b77eb95fad6c29ed5722d9113c55fde120a92d35c7d3fb51bdd11d
DIST vscodium-1.74.1.22349-arm64.tar.gz 114469077 BLAKE2B 3751a2a25d32917fd71e782a168638ecd387ccd41ab62e79d3b5dfb49b5e169e1030df72ee2551c75fc8add434791497d13020b8bf96addb403f18ff0829b5ff SHA512 16f6c09762773ab4ac695c97f9458464ecdcb30f06023122e94278758424fd127d0921779e6f04e496cd004994b1996b276812eb11423d08fb4060fee60df4ed
+DIST vscodium-1.74.2.22355-amd64.tar.gz 121392747 BLAKE2B c94de3bb8f0bce582aa0dc983f6215be2a0c21676e57a0a9eed63f667708f2ed3694f84041c9e6a4aeaf6aa6c86d3ca8d9801358af93a127ec7b12ccf2b07870 SHA512 b1e6bac2a3d08a903a2906f0b514e64e44a50d6be1318214431a3d851010c724dcb7e1e28a1e01ab7e09fdf486cbf667040e4b80084a0be62125c814160326e7
+DIST vscodium-1.74.2.22355-arm.tar.gz 103437753 BLAKE2B 215a7bc9e5f5137742885b3bb06e3e45fbc6b9c267b1653db04ee746e69794ba2be789c59322e80a486a63c38744cd471c0a9b3b0ce1a52222e4d86e2f38a16b SHA512 c556b7e0413c0e4af098c8f5443cbe3c58a4a7ede8b5fe5dadb8f1faa97413c006a430702ad93002950584ca94d10cdd22465e7f37de6b1bb8af1f430644a505
+DIST vscodium-1.74.2.22355-arm64.tar.gz 114464524 BLAKE2B 3c2e166ef1bee641c3082267fe62ae80858c044f5aae62c656c95288282174e81a3961465b45222fe3dd97abfdb2a4e81c2969e0e0d95981c783dbebf23266b0 SHA512 6b956d286a6a335bd87b321b353f5e857844c6ab8b45bfeb141cd49ab0d42d62f3d857270001ebd77eef81dbdd53671c8de84861e61b87186533580f7e00e5b1
diff --git a/app-editors/vscodium/vscodium-1.74.2.22355.ebuild b/app-editors/vscodium/vscodium-1.74.2.22355.ebuild
new file mode 100644
index 000000000000..64ee4a6f829e
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.74.2.22355.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}