summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 00:20:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-17 16:40:11 +0100
commitd24b70d988eb3212ee9c6ceea1a00cc8618562c8 (patch)
tree8085c88ed64280797789dbce0cdc4d383a4aa4cd /app-editors
parentapp-admin/conky: Remove old. (diff)
downloadgentoo-d24b70d988eb3212ee9c6ceea1a00cc8618562c8.tar.gz
gentoo-d24b70d988eb3212ee9c6ceea1a00cc8618562c8.tar.bz2
gentoo-d24b70d988eb3212ee9c6ceea1a00cc8618562c8.zip
app-editors/wxhexeditor: EAPI-7 bump, fix desktop file, HOMEPAGE
Closes: https://bugs.gentoo.org/733762 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch13
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.24-r1.ebuild43
2 files changed, 56 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch
new file mode 100644
index 000000000000..7d3d54da09ab
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch
@@ -0,0 +1,13 @@
+Index: resources/wxHexEditor.desktop
+===================================================================
+--- a/resources/wxHexEditor.desktop 2017-03-16 05:50:42.000000000 +0200
++++ b/resources/wxHexEditor.desktop 2017-03-24 12:16:39.931400635 +0200
+@@ -8,6 +8,7 @@ Exec=wxHexEditor
+ Icon=wxHexEditor
+ Terminal=false
+ Type=Application
+-Categories=Utility;TextEditor;Utility;
++Categories=Utility;TextEditor;
++Keywords=disk;drive;volume;harddisk;hdd;disc;cdrom;dvd;partition;iso;image;backup;restore;editor;
+ Keywords[en_GB]=disk;drive;volume;harddisk;hdd;disc;cdrom;dvd;partition;iso;image;backup;restore;editor;
+
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.24-r1.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.24-r1.ebuild
new file mode 100644
index 000000000000..a31c4b0aa439
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.24-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="wxHexEditor"
+WX_GTK_VER=3.0-gtk3
+inherit toolchain-funcs wxwidgets
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files"
+HOMEPAGE="https://github.com/EUA/wxHexEditor"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-crypt/mhash
+ dev-libs/udis86
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-syslibs.patch
+ "${FILESDIR}"/${P}-desktop.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+}