summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErvin Peters <coder@ervnet.de>2020-08-11 15:29:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-21 10:14:44 +0300
commitdbe0cbd3f6fd845bd57ab2e41d006f24f5be1e6f (patch)
tree9861144fb8455018381b9f77733001a454babb48 /app-editors
parentapp-editors/scite: removed old versions (diff)
downloadgentoo-dbe0cbd3f6fd845bd57ab2e41d006f24f5be1e6f.tar.gz
gentoo-dbe0cbd3f6fd845bd57ab2e41d006f24f5be1e6f.tar.bz2
gentoo-dbe0cbd3f6fd845bd57ab2e41d006f24f5be1e6f.zip
app-editors/scite: sed fixes
fixed makefile CXX var errors Bug: https://bugs.gentoo.org/728426 CLOSES: https://bugs.gentoo.org/728426 Signed-off-by: Ervin Peters <coder@ervnet.de> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/scite-4.2.1.ebuild8
-rw-r--r--app-editors/scite/scite-4.3.3.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/app-editors/scite/scite-4.2.1.ebuild b/app-editors/scite/scite-4.2.1.ebuild
index 6b9aa913c832..648761d8d38b 100644
--- a/app-editors/scite/scite-4.2.1.ebuild
+++ b/app-editors/scite/scite-4.2.1.ebuild
@@ -47,18 +47,20 @@ pkg_pretend() {
}
src_prepare() {
+ tc-export AR CC CXX RANLIB
+
# remove hardcoded CC, Optimizations and clang unknown flags
sed -i "${WORKDIR}/scintilla/gtk/makefile" \
-e "s#^CC = gcc#CC = ${CC}#" \
-e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CC = ${CXX}#" \
+ -e "s#^CXX = clang++#CXX = ${CXX}#" \
-e "s#-Os##" \
-e "s#-Wno-misleading-indentation##" \
|| die "error patching /scintilla/gtk/makefile"
sed -i "${S}/makefile" \
-e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CC = ${CXX}#" \
+ -e "s#^CXX = clang++#CXX = ${CXX}#" \
-e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
-e "s#-Os##" \
|| die "error patching gtk/makefile"
@@ -72,7 +74,7 @@ src_prepare() {
# add the ebuild suffix as shell type for working with ebuilds
sed -i "${WORKDIR}/scite/src/perl.properties" \
-e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.prperties"
+ || die "error patching /scite/src/perl.properties"
# it seems that pwd here is ${S}, but user patches are relative to ${workdir}
# Bug #576162
diff --git a/app-editors/scite/scite-4.3.3.ebuild b/app-editors/scite/scite-4.3.3.ebuild
index 186e3d50d591..9878fd6a6b64 100644
--- a/app-editors/scite/scite-4.3.3.ebuild
+++ b/app-editors/scite/scite-4.3.3.ebuild
@@ -50,18 +50,20 @@ pkg_pretend() {
}
src_prepare() {
+ tc-export AR CC CXX RANLIB
+
# remove hardcoded CC, Optimizations and clang unknown flags
sed -i "${WORKDIR}/scintilla/gtk/makefile" \
-e "s#^CC = gcc#CC = ${CC}#" \
-e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CC = ${CXX}#" \
+ -e "s#^CXX = clang++#CXX = ${CXX}#" \
-e "s#-Os##" \
-e "s#-Wno-misleading-indentation##" \
|| die "error patching /scintilla/gtk/makefile"
sed -i "${S}/makefile" \
-e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CC = ${CXX}#" \
+ -e "s#^CXX = clang++#CXX = ${CXX}#" \
-e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
-e "s#-Os##" \
|| die "error patching gtk/makefile"
@@ -75,7 +77,7 @@ src_prepare() {
# add the ebuild suffix as shell type for working with ebuilds
sed -i "${WORKDIR}/scite/src/perl.properties" \
-e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.prperties"
+ || die "error patching /scite/src/perl.properties"
# it seems that pwd here is ${S}, but user patches are relative to ${workdir}
# Bug #576162