summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-11-11 01:57:11 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-12 16:01:55 +0100
commite8550bc4c91bd0a95a71979a00357910939d7021 (patch)
tree7ad0a6df56e0f17d6659ea444ba35d9061c5f52d /app-editors
parentapp-editors/kakoune: version bump to 0_pre20161111 (diff)
downloadgentoo-e8550bc4c91bd0a95a71979a00357910939d7021.tar.gz
gentoo-e8550bc4c91bd0a95a71979a00357910939d7021.tar.bz2
gentoo-e8550bc4c91bd0a95a71979a00357910939d7021.zip
app-editors/kakoune: update live ebuild
introduce static use flag Closes: https://github.com/gentoo/gentoo/pull/2802 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kakoune/kakoune-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-editors/kakoune/kakoune-9999.ebuild b/app-editors/kakoune/kakoune-9999.ebuild
index cee92150dfc9..4a1339be1703 100644
--- a/app-editors/kakoune/kakoune-9999.ebuild
+++ b/app-editors/kakoune/kakoune-9999.ebuild
@@ -13,10 +13,10 @@ EGIT_REPO_URI="https://github.com/mawww/kakoune.git"
LICENSE="Unlicense"
SLOT="0"
KEYWORDS=""
-IUSE="debug"
+IUSE="debug static"
RDEPEND="
- sys-libs/ncurses:=[unicode]
+ sys-libs/ncurses:0=[unicode]
dev-libs/boost:=
"
DEPEND="
@@ -25,9 +25,9 @@ DEPEND="
${RDEPEND}
"
-PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+PATCHES=( "${FILESDIR}/${PN}-0_pre20161111-makefile.patch" )
-pkg_pretend() {
+pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]]; then
if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
die "Clang or GCC >=5.0 is required to build this version"
@@ -38,11 +38,11 @@ pkg_pretend() {
src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
- export CXX=$(tc-getCXX)
+ tc-export CXX
export debug=$(usex debug)
- S="${WORKDIR}/${P}/src"
+ export static=$(usex static)
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" docdir="${D}/usr/share/doc/${PF}" install
+ emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
}