summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-16 16:07:34 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-06-04 17:16:57 +0200
commitef1db3f5e7a31dc66f88a90435544f7a5231e10a (patch)
tree080704979c832fbf33b2f565866cbc78e2250877 /app-editors
parentx11-misc/mozo: Version bump to 1.18.0 (diff)
downloadgentoo-ef1db3f5e7a31dc66f88a90435544f7a5231e10a.tar.gz
gentoo-ef1db3f5e7a31dc66f88a90435544f7a5231e10a.tar.bz2
gentoo-ef1db3f5e7a31dc66f88a90435544f7a5231e10a.zip
app-editors/pluma: Version bump to 1.18.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/pluma/Manifest1
-rw-r--r--app-editors/pluma/pluma-1.18.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index d444a0347bd2..a349d4845893 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,3 +1,4 @@
DIST pluma-1.12.2.tar.xz 3397280 SHA256 eb74988a9fa9892f883b2ccdc9cf217478576815bcb02662d2e3cf2ae39ef870 SHA512 db2878161903868703514531ba214fc34dad1789885f18756e9192d6ba17950c8be03141ada72f8c386b515d8b0f9d58a0ee94a33fe3ffe00f360ea667c2b275 WHIRLPOOL 30e45dc3e399e77403d23ebe1c8fb98592f3a408de3bd5ee724e621168b26116de0c520348dd74929e360a251b8d727ef9967746b14732fc6e03d63ffb3091c4
DIST pluma-1.14.1.tar.xz 3415364 SHA256 5517e9bf93ec22a3036498f2e95652fb9046229b8a0da66a742643eab7e595a1 SHA512 5d04e053ab2eb0f90e34d9af541004867c7317fd9386229c4e702e95a80420df16b20e4ae4c30bbee79fe904282f6134f7c361971be07cd6952612d975c88d11 WHIRLPOOL 217d447f0ebe9bcf069b6831421e9680256c7b70753ab126aaf5641ba518df12b4fc60041feb433873a0cbc2d7108bf871958e13186b71e050d9f0610db9b770
DIST pluma-1.16.0.tar.xz 3412640 SHA256 0eb4a4486f1c83119969567cedb05894f25ac5d43cefb4c3ed88ca2f75eff29d SHA512 2472a1631cb89f4df0d09558bd274b6c6d042ae4cbb6ae0134a089cfefb5d0673ec28d78d3665dd1933f76a9c20517afe626f921e06703af9e3c71b9f3b96260 WHIRLPOOL 74c57e589e0f1c2013eb01b1c1aa9e455b0741486f5e1537588f641521fb180b6f7f7a02a9512e069dd94a1d9111fd3d52000a3c05adf30f84ef2ebbadeb0c22
+DIST pluma-1.18.2.tar.xz 3348500 SHA256 ff0f29d4eaa946cbb2b26bbdc2b2d5a308b2d16ec99ea384bcb13f1f3d1a09fc SHA512 285170531c92ad13fdd35286c06de62b75f0426a830c51f4f54799b4b5377d65b3e1fd1e1af3827462a356947e853e4203a4ed394a8b6137bbd87e289f490b6d WHIRLPOOL 13ede09dcede35be84797a3c597fbb1b3fc06aaf866dab17a831c19c577a22aa61af7b5758221a971cc6244bc2c966041228911947ecbaca59292b98d3c4da7d
diff --git a/app-editors/pluma/pluma-1.18.2.ebuild b/app-editors/pluma/pluma-1.18.2.ebuild
new file mode 100644
index 000000000000..65d4d2f88bc0
--- /dev/null
+++ b/app-editors/pluma/pluma-1.18.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate multilib python-single-r1 virtualx
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+introspection spell"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
+# https://github.com/mate-desktop/mate-text-editor/issues/33
+RESTRICT="test"
+
+COMMON_DEPEND="dev-libs/atk:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14.0:3[introspection?]
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ x11-libs/libICE:0
+ x11-libs/libX11:0
+ >=x11-libs/libSM-1.0
+ x11-libs/pango:0
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.2:0
+ >=app-text/iso-codes-0.35:0
+ )
+ !!app-editors/mate-text-editor"
+
+RDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}
+ >=mate-base/mate-desktop-1.9[introspection?]"
+
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/rarian:0
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.17:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}