summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-06-16 16:50:10 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-06-16 16:50:10 +0300
commitf339dbab03279157499a336780b0406590a16eae (patch)
treeff6690400830acb6afc1d1515a71f49dd45e0a37 /app-editors
parentdev-python/contourpy: Keyword 1.1.0 hppa, #908478 (diff)
downloadgentoo-f339dbab03279157499a336780b0406590a16eae.tar.gz
gentoo-f339dbab03279157499a336780b0406590a16eae.tar.bz2
gentoo-f339dbab03279157499a336780b0406590a16eae.zip
app-editors/vscode: add 1.79.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.79.2.ebuild122
2 files changed, 125 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 28a34bf7b4f3..5d667181c4a5 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -4,3 +4,6 @@ DIST vscode-1.79.0-arm64.tar.gz 130967654 BLAKE2B fe5a484b12ad1ef6c9cccbe95cab14
DIST vscode-1.79.1-amd64.tar.gz 134787612 BLAKE2B 65b8cd1695c92dc3d1cd3cf1ddd5b2e048ed8df3bd0d8284bff6a1980947adbc9fb85fe48a79ce20405151d33422c6f0677a4a2cf7cbb572eff6b866d9f951d1 SHA512 15f48715bffe22aceada44cc5da3b7e47983e3acb5ecc04aca5babe465f2da0c2dd143540f231ce6d8e3f6879d66b494d9be57afa23161ab65448430f294ea2c
DIST vscode-1.79.1-arm.tar.gz 119311072 BLAKE2B 5f6a48fb3b915894aa90488c0c80fd47d886c614d46821a61a3d97899e4d8c02a22730944f50e1ecc4c7f729db19ef054e3e46be570d6a19e63a8b730084b41e SHA512 f61c3bb2570621c3e20b3b056e4d06178a674e63d9fbc132f885734ba5ec030456177657e81c7d2a98054dce4dde2ca6387d8c84841dc26c0dd6bcea1dc386aa
DIST vscode-1.79.1-arm64.tar.gz 130964437 BLAKE2B ae7d5a14a0d31de1ac984f74805191d3323cad8861949c4cbf342e7f6e5b0a4d5ee046ad314be4eb39b33e17120a700964c9d7696922ac1fd487d7e1b5374915 SHA512 e99fed7bdf7b8557cdcaa4bfe5ee7509dd34a34e6643f522439736d84d172070586cf7216b9d06f3110bdb2487bbd389777ee2a14929c04c963db982196e2a87
+DIST vscode-1.79.2-amd64.tar.gz 134757908 BLAKE2B 8f92476935a7833cbb872d41b65d480540860a529f587009e1188d3aaa1dc61b19ca11ee472ebf7942d5f763bee940fb28b4066a67346094aa5efd519456fd5c SHA512 14aded59f7b083a1c57c50ff24064c242520c6520811541f5cd4daa9ab3878eae4a88c8e0ba54bfe3ec1023395e5b2f4f74cecd373d8bc43acbdb15fdd1fc47f
+DIST vscode-1.79.2-arm.tar.gz 119307976 BLAKE2B 89b48809c3306ff89057f7533c825bfce9f35792be4b308b254bc4e347ead14c3e89a00c70ce678287e2e8376a76997c4a43dbb4dd3209cfaebe4a432d5a0bfc SHA512 9f83a0ae95fb6fead3fe2da3ce96e6be336713a29bd28fa0db168ce3236d4eaf80067e9ca1ff0cd3ebb7d31d9789f262a0119524afe042f75b58bcb953937ca5
+DIST vscode-1.79.2-arm64.tar.gz 130972979 BLAKE2B da5c86ac8bfe4d7900aec6dbd61de03555e94a8c36ca504024b5fa0c217f2473fc13a1e0ef0fa32779ae0793f6574fceae693381370b068d574bc0d1fa8649e0 SHA512 76050ff4fd73a3cc285781f03c087388d8717d5fbb31807f271da9bca77d10ac909844dc9ec1b30e85dd5a76a76ac5b027d200acf0d4445c5d5fb88bdea1104a
diff --git a/app-editors/vscode/vscode-1.79.2.ebuild b/app-editors/vscode/vscode-1.79.2.ebuild
new file mode 100644
index 000000000000..0362e867fb48
--- /dev/null
+++ b/app-editors/vscode/vscode-1.79.2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscode/chrome_crashpad_handler
+ /opt/vscode/chrome-sandbox
+ /opt/vscode/code
+ /opt/vscode/libEGL.so
+ /opt/vscode/libffmpeg.so
+ /opt/vscode/libGLESv2.so
+ /opt/vscode/libvk_swiftshader.so
+ /opt/vscode/libvulkan.so*
+ /opt/vscode/resources/app/extensions/*
+ /opt/vscode/resources/app/node_modules.asar.unpacked/*
+ /opt/vscode/swiftshader/libEGL.so
+ /opt/vscode/swiftshader/libGLESv2.so
+"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+ dosym -r "/opt/${PN}/bin/code-tunnel" "usr/bin/code-tunnel"
+ domenu "${FILESDIR}/vscode.desktop"
+ domenu "${FILESDIR}/vscode-url-handler.desktop"
+ domenu "${FILESDIR}/vscode-wayland.desktop"
+ domenu "${FILESDIR}/vscode-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}