summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-30 16:16:49 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-30 18:57:32 -0700
commitf869b5fb949a08a46eab10ddca62cb7bcf8c39e0 (patch)
treebdb76dfb408bcb805b8a014107f632e1402378af /app-editors
parentapp-editors/gedit: Drop old versions (diff)
downloadgentoo-f869b5fb949a08a46eab10ddca62cb7bcf8c39e0.tar.gz
gentoo-f869b5fb949a08a46eab10ddca62cb7bcf8c39e0.tar.bz2
gentoo-f869b5fb949a08a46eab10ddca62cb7bcf8c39e0.zip
app-editors/gedit-plugins: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild108
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-40.0.ebuild108
3 files changed, 0 insertions, 218 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 088c611baafc..0b10f6559558 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1 @@
-DIST gedit-plugins-3.38.1.tar.xz 957616 BLAKE2B 9cf5fe5343b513bd841add5d4e85f8fe2e8f62524af7c124bdfc41b81e653a41d1a7417f8cc06f764cca730927f471598cae914a1581c5cd3712b89c464a075d SHA512 d5cc3e82ac6a488f5ab06eaf4eb5ad32bdbe50b74f2f215e114b5cb3bb0a089da00caa3815d6638a679c1c902983a0754a16ef88e15ff88d8321a247288ad237
-DIST gedit-plugins-40.0.tar.xz 950560 BLAKE2B 783803dd4913a2b384a714c7564f18686b6ecf7da2f10d421322b6421e9b10271f97dcbf819e3212c97a0e4ba2b54dcb12ba5efc392396caafe705844e2cd407 SHA512 660e82dc1a1187262afd921196074dd2808a400b5acbc88ab36f522c50f1b9d221ff1821c2e8c0c066c7556862779e8d277f52a758070c59b17e6b53791ff39d
DIST gedit-plugins-40.1.tar.xz 951024 BLAKE2B 8a5fa07d6b9a5848e66de995c05f389b288e7863fa506476fd82157dc203e472b8ac8b8bdd15b09513e5d819fc58ce4d1077e62e6c5b90f93b14775052bf2737 SHA512 71649d157ac5591e4dd317c44ae167c98fb59e253c45f8c1ff8ef397a9e3f0bb968f0ef2486f9021354269e77defb9e5e305f1538f69818480a250966143c7a3
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild
deleted file mode 100644
index 710d8c041c40..000000000000
--- a/app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="xml"
-VALA_MIN_API_VERSION="0.28"
-
-inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
-
-DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
-
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-SLOT="0"
-
-IUSE="charmap git +python terminal vala"
-REQUIRED_USE="
- charmap? ( python )
- git? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- terminal? ( python )
-"
-
-RDEPEND="
- >=dev-libs/libpeas-1.14.1[gtk]
- >=app-editors/gedit-3.38
-
- >=dev-libs/glib-2.32:2
- >=x11-libs/gtk+-3.9:3
- >=x11-libs/gtksourceview-4.0.2:4
-
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=app-editors/gedit-3.36[python,${PYTHON_SINGLE_USEDEP}]
- dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
- >=dev-python/dbus-python-0.82[${PYTHON_MULTI_USEDEP}]
- dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
- ')
- >=x11-libs/gtk+-3.9:3[introspection]
- >=x11-libs/gtksourceview-4.0.2:4[introspection]
- x11-libs/pango[introspection]
- x11-libs/gdk-pixbuf:2[introspection]
- )
- charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
- git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
- terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
-" # vte-0.52+ for feed_child API compatibility
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/libxml2
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- use vala && vala_src_prepare
- xdg_src_prepare
-}
-
-src_configure() {
- local emesonargs=(
- -Dplugin_bookmarks=true
- $(meson_use python plugin_bracketcompletion)
- $(meson_use charmap plugin_charmap)
- $(meson_use python plugin_codecomment)
- $(meson_use python plugin_colorpicker)
- $(meson_use python plugin_colorschemer)
- $(meson_use python plugin_commander)
- -Dplugin_drawspaces=true
- $(meson_use vala plugin_findinfiles)
- $(meson_use git plugin_git)
- $(meson_use python plugin_joinlines)
- $(meson_use python plugin_multiedit)
- $(meson_use python plugin_sessionsaver)
- $(meson_use python plugin_smartspaces)
- $(meson_use python plugin_synctex)
- $(meson_use terminal plugin_terminal)
- $(meson_use python plugin_textsize)
- $(meson_use python plugin_translate)
- -Dplugin_wordcompletion=true
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/app-editors/gedit-plugins/gedit-plugins-40.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-40.0.ebuild
deleted file mode 100644
index 615262ea716c..000000000000
--- a/app-editors/gedit-plugins/gedit-plugins-40.0.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="xml"
-VALA_MIN_API_VERSION="0.28"
-
-inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
-
-DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
-
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-IUSE="charmap git +python terminal vala"
-REQUIRED_USE="
- charmap? ( python )
- git? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- terminal? ( python )
-"
-
-RDEPEND="
- >=dev-libs/libpeas-1.14.1[gtk]
- >=app-editors/gedit-40.0
-
- >=dev-libs/glib-2.32:2
- >=x11-libs/gtk+-3.9:3
- >=x11-libs/gtksourceview-4.0.2:4
-
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
- dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
- >=dev-python/dbus-python-0.82[${PYTHON_MULTI_USEDEP}]
- dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
- ')
- >=x11-libs/gtk+-3.9:3[introspection]
- >=x11-libs/gtksourceview-4.0.2:4[introspection]
- x11-libs/pango[introspection]
- x11-libs/gdk-pixbuf:2[introspection]
- )
- charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
- git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
- terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
-" # vte-0.52+ for feed_child API compatibility
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/libxml2
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- use vala && vala_src_prepare
- xdg_src_prepare
-}
-
-src_configure() {
- local emesonargs=(
- -Dplugin_bookmarks=true
- $(meson_use python plugin_bracketcompletion)
- $(meson_use charmap plugin_charmap)
- $(meson_use python plugin_codecomment)
- $(meson_use python plugin_colorpicker)
- $(meson_use python plugin_colorschemer)
- $(meson_use python plugin_commander)
- -Dplugin_drawspaces=true
- $(meson_use vala plugin_findinfiles)
- $(meson_use git plugin_git)
- $(meson_use python plugin_joinlines)
- $(meson_use python plugin_multiedit)
- $(meson_use python plugin_sessionsaver)
- $(meson_use python plugin_smartspaces)
- $(meson_use python plugin_synctex)
- $(meson_use terminal plugin_terminal)
- $(meson_use python plugin_textsize)
- $(meson_use python plugin_translate)
- -Dplugin_wordcompletion=true
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}