summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2020-01-27 10:32:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-28 17:03:24 +0200
commitfa2815f29cd127ca2841d0ed671d3262e5ba7da9 (patch)
treec9b7d66e3215777b63737bf4a0f140f6b67ca285 /app-editors
parentnet-im/signal-desktop-bin: fix rpath of broken lib (diff)
downloadgentoo-fa2815f29cd127ca2841d0ed671d3262e5ba7da9.tar.gz
gentoo-fa2815f29cd127ca2841d0ed671d3262e5ba7da9.tar.bz2
gentoo-fa2815f29cd127ca2841d0ed671d3262e5ba7da9.zip
app-editors/gummi: Bump to 0.8.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/Manifest1
-rw-r--r--app-editors/gummi/gummi-0.8.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/gummi/Manifest b/app-editors/gummi/Manifest
index e8d96e68b76d..aba0b0e9edcc 100644
--- a/app-editors/gummi/Manifest
+++ b/app-editors/gummi/Manifest
@@ -1,2 +1,3 @@
DIST gummi-0.6.6.tar.gz 792642 BLAKE2B 4f6096999b06361811a9149fa08eff5d2315f01e55539c5849c4bc86aab5a482ad9a0adfe84de5d093e66a328b294b4d88e1e2e2f0355bab320f0c094581da97 SHA512 3be94927c9aafa4914ed2b6f6f5022dce5bcca315a1f947fafb8a4c8bbc5a2bc57f07f8ceaaacdd0b92a5a30483ea8b00e570faf62479280d2ad874716e4c47d
DIST gummi-0.8.0.tar.gz 580933 BLAKE2B f0591d1acf244edb4cd2a6db109532b84dd0ec741e4575c1bdc690e0763a73ebe8e8882c328627908d9cc0c23ba50e94d1d0e5cea95e60a22d0a369cd4a1f8c1 SHA512 a4ae897a9f3f6f1dabb70a09801e83e0675934298caa022ddeb2c84f90d418cbc5b1a0e02b4b021f40daa784f145b5136b53ce70acf3e4834eea04afcb663b2b
+DIST gummi-0.8.1.tar.gz 580887 BLAKE2B ce06df4e85e2dfd510e39aeab785d1289335802fd24fa0b25eb9a0b920849d7ab2b89d62509e91ddb41c8f4c601544f3da8819f69ff3e38fc59dbde0aa3e789d SHA512 dccef28f6ceb2743a5a44c5224cce7326e9bb9e6f1baccb51c23d801ce595914d1b960fe11d230dcad5f041d80fe57b46c0e5aa9c6abd881dd2e32db373d329a
diff --git a/app-editors/gummi/gummi-0.8.1.ebuild b/app-editors/gummi/gummi-0.8.1.ebuild
new file mode 100644
index 000000000000..df951917e006
--- /dev/null
+++ b/app-editors/gummi/gummi-0.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="https://github.com/alexandervdm/gummi"
+SRC_URI="https://github.com/alexandervdm/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/gtkspell:3
+ app-text/poppler[cairo]
+ dev-libs/glib:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Gummi supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-**-"
+ elog "packages for your language of choice."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}