summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2021-05-26 11:27:32 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-15 10:27:38 +0300
commitff008adc36d9d8d713c2c7f8134e99ce56f17fd9 (patch)
tree9a49650391770f58c466211ff98aa09d6599a261 /app-editors
parentnet-voip/captagent: add subslot binder to openssl (diff)
downloadgentoo-ff008adc36d9d8d713c2c7f8134e99ce56f17fd9.tar.gz
gentoo-ff008adc36d9d8d713c2c7f8134e99ce56f17fd9.tar.bz2
gentoo-ff008adc36d9d8d713c2c7f8134e99ce56f17fd9.zip
app-editors/gummi: Bump to 0.8.2
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/20993 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/Manifest1
-rw-r--r--app-editors/gummi/gummi-0.8.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/gummi/Manifest b/app-editors/gummi/Manifest
index b7602e361361..e20ee04bf935 100644
--- a/app-editors/gummi/Manifest
+++ b/app-editors/gummi/Manifest
@@ -1 +1,2 @@
DIST gummi-0.8.1.tar.gz 580887 BLAKE2B ce06df4e85e2dfd510e39aeab785d1289335802fd24fa0b25eb9a0b920849d7ab2b89d62509e91ddb41c8f4c601544f3da8819f69ff3e38fc59dbde0aa3e789d SHA512 dccef28f6ceb2743a5a44c5224cce7326e9bb9e6f1baccb51c23d801ce595914d1b960fe11d230dcad5f041d80fe57b46c0e5aa9c6abd881dd2e32db373d329a
+DIST gummi-0.8.2.tar.gz 595733 BLAKE2B 9c7366df2b8fe40f7876f065a1156eb4992048b3eaec5dde332c50ccb98ef2a5d8d2cbe73ebb56eb3736bbce49f3168f165db82f562ee7265ce0859952801a2c SHA512 3882f1e2779b94348cc0cc243c3968a78165c16de41029f9fcb8ba2fa942d329c43f5ecc8ba8327590e14343556ca472a51d1e824ce0985a415ab92aa2cbbc42
diff --git a/app-editors/gummi/gummi-0.8.2.ebuild b/app-editors/gummi/gummi-0.8.2.ebuild
new file mode 100644
index 000000000000..9e9ee99f8505
--- /dev/null
+++ b/app-editors/gummi/gummi-0.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="https://github.com/alexandervdm/gummi"
+SRC_URI="https://github.com/alexandervdm/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ app-text/gtkspell:3
+ app-text/poppler[cairo]
+ dev-libs/glib:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Gummi supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-**-"
+ elog "packages for your language of choice."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}