summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-31 02:09:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-31 02:26:18 +0200
commit5f9d54dce7b891b120b8122e40bbe2cebc24e190 (patch)
treef1b8964bd6b85310245810f659250d682ca70ad6 /app-emacs/assess
parentapp-emacs/m-buffer: new package; add version 0.15 (diff)
downloadgentoo-5f9d54dce7b891b120b8122e40bbe2cebc24e190.tar.gz
gentoo-5f9d54dce7b891b120b8122e40bbe2cebc24e190.tar.bz2
gentoo-5f9d54dce7b891b120b8122e40bbe2cebc24e190.zip
app-emacs/assess: new package; add version 0.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/assess')
-rw-r--r--app-emacs/assess/Manifest1
-rw-r--r--app-emacs/assess/assess-0.6.ebuild33
-rw-r--r--app-emacs/assess/files/50assess-gentoo.el1
-rw-r--r--app-emacs/assess/metadata.xml24
4 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/assess/Manifest b/app-emacs/assess/Manifest
new file mode 100644
index 000000000000..1379624d930f
--- /dev/null
+++ b/app-emacs/assess/Manifest
@@ -0,0 +1 @@
+DIST assess-0.6.tar.gz 20771 BLAKE2B 29e8f84c20575314271d9a08ed3ac93f28f1c1b5c2df2ac35e397226f4eea033210ff9b96c90a282a44c60e301f5abc38be88efc74c21a2a7fdc29340d6d43e5 SHA512 ff50731867646f07b8c6f3edd1123695d008fa5265ab8b3543cbf32a54a4a0415a91304067e0dacf53890850b56377594802c9763601616bd828316f7a8cef69
diff --git a/app-emacs/assess/assess-0.6.ebuild b/app-emacs/assess/assess-0.6.ebuild
new file mode 100644
index 000000000000..6d09c2dc615c
--- /dev/null
+++ b/app-emacs/assess/assess-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Test support functions for Emacs"
+HOMEPAGE="https://github.com/phillord/assess/"
+SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/m-buffer"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/load-relative )
+"
+
+DOCS=( README.md )
+
+# Remove a test helper accessing the network, luckily unnecessary
+ELISP_REMOVE="test/local-sandbox.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l assess-discover -f assess-discover-run-and-exit-batch || die
+}
diff --git a/app-emacs/assess/files/50assess-gentoo.el b/app-emacs/assess/files/50assess-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/assess/files/50assess-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/assess/metadata.xml b/app-emacs/assess/metadata.xml
new file mode 100644
index 000000000000..79e64c29fbc3
--- /dev/null
+++ b/app-emacs/assess/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Assess provides additional support for testing Emacs packages. It provides:
+ a set of predicates for comparing strings, buffers and file contents,
+ explainer functions for all predicates giving useful output, macros for
+ creating many temporary buffers at once, and for restoring the buffer list,
+ methods for testing indentation, by comparison or "roundtripping", methods
+ for testing fontification.
+ Assess aims to be a stateless as possible, leaving Emacs unchanged whether
+ the tests succeed or fail, with respect to buffers, open files and so on;
+ this helps to keep tests independent from each other.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/phillord/assess/issues/</bugs-to>
+ <remote-id type="github">phillord/assess</remote-id>
+ </upstream>
+</pkgmetadata>