summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-27 19:36:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-27 19:59:45 +0100
commit1aed32d91feb2308f048799b41c8a754d64f3694 (patch)
treedf76514dc0c8dd5c897717bfe7d11cbd1425cf99 /app-emacs/async/async-1.9.8.ebuild
parentapp-containers/skopeo: style fix (diff)
downloadgentoo-1aed32d91feb2308f048799b41c8a754d64f3694.tar.gz
gentoo-1aed32d91feb2308f048799b41c8a754d64f3694.tar.bz2
gentoo-1aed32d91feb2308f048799b41c8a754d64f3694.zip
app-emacs/async: bump to 1.9.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/async/async-1.9.8.ebuild')
-rw-r--r--app-emacs/async/async-1.9.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/async/async-1.9.8.ebuild b/app-emacs/async/async-1.9.8.ebuild
new file mode 100644
index 000000000000..bdc3e15862b2
--- /dev/null
+++ b/app-emacs/async/async-1.9.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}