summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-20 18:23:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-20 18:27:00 +0200
commitdbd92b21a401a19a14e44aba2458f21898737e75 (patch)
treedcc2c68812b1937dd3ecdecd0ffefbd26a705393 /app-emacs/avy-embark-collect/avy-embark-collect-0.23.ebuild
parentdev-dotnet/nake: new package; add 3.0.0 (diff)
downloadgentoo-dbd92b21a401a19a14e44aba2458f21898737e75.tar.gz
gentoo-dbd92b21a401a19a14e44aba2458f21898737e75.tar.bz2
gentoo-dbd92b21a401a19a14e44aba2458f21898737e75.zip
app-emacs/avy-embark-collect: bump to 0.23
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/avy-embark-collect/avy-embark-collect-0.23.ebuild')
-rw-r--r--app-emacs/avy-embark-collect/avy-embark-collect-0.23.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/avy-embark-collect/avy-embark-collect-0.23.ebuild b/app-emacs/avy-embark-collect/avy-embark-collect-0.23.ebuild
new file mode 100644
index 000000000000..115994eb1e68
--- /dev/null
+++ b/app-emacs/avy-embark-collect/avy-embark-collect-0.23.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use avy to jump to Embark Collect entries"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/oantolin/embark.git"
+else
+ SRC_URI="https://github.com/oantolin/embark/archive/${PV}.tar.gz
+ -> embark-${PV}.tar.gz"
+ S="${WORKDIR}/embark-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/avy
+ app-emacs/embark
+"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="embark-consult.el embark-org.el embark.el"
+
+SITEFILE="50${PN}-gentoo.el"