summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/bbdb/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/bbdb/files')
-rw-r--r--app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el2
-rw-r--r--app-emacs/bbdb/files/50bbdb-gentoo.el4
-rw-r--r--app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch126
3 files changed, 132 insertions, 0 deletions
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el b/app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el
new file mode 100644
index 000000000000..45a7cc208e0d
--- /dev/null
+++ b/app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'bbdb-loaddefs)
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo.el b/app-emacs/bbdb/files/50bbdb-gentoo.el
new file mode 100644
index 000000000000..7953b3c852a4
--- /dev/null
+++ b/app-emacs/bbdb/files/50bbdb-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'load-path "@SITELISP@/bits")
+(require 'bbdb)
+(bbdb-initialize)
diff --git a/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch b/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch
new file mode 100644
index 000000000000..85dbc0374e32
--- /dev/null
+++ b/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch
@@ -0,0 +1,126 @@
+Patch from upstream, backported to bbdb-3.1.2.
+
+From e028f4d8f04c3db663db023cf5a630461cfda2bd Mon Sep 17 00:00:00 2001
+From: Roland Winkler <winkler@gnu.org>
+Date: Wed, 23 Jul 2014 03:27:09 +0000
+Subject: Do not load init file or site file for byte compilation
+
+--- bbdb-3.1.2-orig/lisp/Makefile.am
++++ bbdb-3.1.2/lisp/Makefile.am
+@@ -20,6 +20,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with BBDB. If not, see <http://www.gnu.org/licenses/>.
+
++# --batch implies --no-init-file, yet let's be explicit about what we want
++AM_ELCFLAGS += --no-init-file --no-site-file
++
+ dist_lisp_LISP = \
+ bbdb.el \
+ bbdb-anniv.el \
+@@ -70,10 +73,11 @@
+ @echo " " >> $@;
+ # Generated autoload-file must have an absolute path,
+ # $srcdir can be relative.
+- $(EMACS) -batch -l autoload \
++ $(EMACS) --batch $(AM_ELCFLAGS) $(ELCFLAGS) \
++ --load autoload \
+ --eval '(setq generated-autoload-file "'$(abs_builddir)/$@'")' \
+ --eval '(setq make-backup-files nil)' \
+- -f batch-update-autoloads $(srcdir)
++ --funcall batch-update-autoloads $(srcdir)
+
+ # Generate bbdb-site.el here as pkgdatadir is only known at "make" time.
+ # We protect the autoconf variables in the sed regular expressions
+--- bbdb-3.1.2-orig/lisp/makefile-temp
++++ bbdb-3.1.2/lisp/makefile-temp
+@@ -43,13 +43,16 @@
+ EMACSOPT =
+
+ # The actual Emacs command run in the targets below.
+-emacs = LC_ALL=C $(EMACS) --batch --directory=./ $(EMACSOPT)
++# --batch implies --no-init-file, yet let's be explicit about what we want
++emacs = LC_ALL=C $(EMACS) --batch --no-init-file --no-site-file \
++ --directory=./ $(EMACSOPT)
++emacs_compile = $(emacs) --funcall batch-byte-compile
+
+-# If you want to use BBDB with VM this should point to your vm/lisp directory.
+-# See also the target all below.
++# VM is not part of GNU Emacs. If you want to use BBDB with VM
++# then the variable VMDIR should point to your vm/lisp directory.
+ VMDIR =
+
+-VM = -eval '(unless (string-match "$(VMDIR)" "") (push "$(VMDIR)" load-path))'
++VM = -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path))'
+
+ .SUFFIXES: .elc .el .tar .Z .gz .uu
+
+@@ -89,51 +92,50 @@
+ @echo " " >> $@;
+ # Generated autoload-file must have an absolute path,
+ # $(srcdir) can be relative.
+- $(emacs) -l autoload \
++ $(emacs) --load autoload \
+ --eval '(setq generated-autoload-file "'`pwd`/$@'")' \
+ --eval '(setq make-backup-files nil)' \
+- -f batch-update-autoloads `pwd`
++ --funcall batch-update-autoloads `pwd`
+
+ .el.elc:
+- $(emacs) -f batch-byte-compile $<
++ $(emacs_compile) $<
+
+ # Not perfect, but better than nothing: If we do not have / do not use
+ # autotools, we simply copy bbdb-site.el.in to bbdb-site.el.
+ bbdb-site.el: bbdb-site.el.in
+ $(CP) $< $@
+ bbdb-site.elc: bbdb-site.el
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ bbdb.elc: bbdb.el bbdb-site.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ bbdb-com.elc: bbdb-com.el bbdb.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-mua.elc: bbdb-mua.el bbdb-com.elc
+- $(emacs) -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path) (load "vm" t t))' \
+- -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path) (load "vm" t t))' \
++ $(@:.elc=.el)
+ bbdb-rmail.elc: bbdb-rmail.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-gnus.elc: bbdb-gnus.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-mhe.elc: bbdb-mhe.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+-# VM is not part of GNU Emacs
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-vm.elc: bbdb-vm.el bbdb-mua.elc
+- $(emacs) $(VM) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(VM) $(@:.elc=.el)
+ bbdb-sc.elc: bbdb-sc.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ bbdb-print.elc: bbdb-print.el bbdb-com.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-migrate.elc: bbdb-migrate.el bbdb.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-anniv.elc: bbdb-anniv.el bbdb-com.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-ispell.elc: bbdb-ispell.el bbdb.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-snarf.elc: bbdb-snarf.el bbdb-com.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ install-el: all
+ $(INSTALL) -d -m 0755 "$(lispdir)/"