summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-03-12 15:49:24 +0100
committerUlrich Müller <ulm@gentoo.org>2020-03-12 15:52:57 +0100
commitdd491221654b5c19d1e63b3061687671e6451e70 (patch)
tree1afeef3f5da031a5142885dd9ffb4788461f60a1 /app-emacs/bbdb
parentapp-emacs/bbdb: Don't install the GNU Info file. (diff)
downloadgentoo-dd491221654b5c19d1e63b3061687671e6451e70.tar.gz
gentoo-dd491221654b5c19d1e63b3061687671e6451e70.tar.bz2
gentoo-dd491221654b5c19d1e63b3061687671e6451e70.zip
app-emacs/bbdb: Version bump to 3.2_pre20180106.
The upstream repo has a v3.2 tag, but there is no release tarball in the download area. The tarball that can be downloaded from cgit is incomplete (e.g., it doesn't contain a configure file). Therefore treat this like a prerelease snapshot and add a _pre suffix. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/bbdb')
-rw-r--r--app-emacs/bbdb/Manifest1
-rw-r--r--app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild62
-rw-r--r--app-emacs/bbdb/files/50bbdb-gentoo-3.2.el4
3 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/bbdb/Manifest b/app-emacs/bbdb/Manifest
index 5c00f00f1fcd..50f7f267031a 100644
--- a/app-emacs/bbdb/Manifest
+++ b/app-emacs/bbdb/Manifest
@@ -1 +1,2 @@
DIST bbdb-3.1.2.tar.gz 378935 BLAKE2B 3fc862d2d68632c997e3f250aa82cced743c3cc3861c74789bb12015ab99745270c79722dc0342334b90f4dd9071ef809ab670a342ac227c24a927870907c25c SHA512 8b32baadc4eb06b0abf533ccb1f540f4f407f27b8d2e847ae25e62d1405e1de5cfc6af16368eecd4086f281ee7a4016cf25568847b3cb798156c7e18e1912576
+DIST bbdb-3.2.tar.gz 189456 BLAKE2B b25efd6a3a156684e0a8f15db056683876c8dd1a44eb585db269746c7424cc18df5407e3a04defcbbd8a2c8438bbe2b16d55ab290e842951f6e475bfc34871fe SHA512 593ba5143b50f2818c19c94452efb2c5d7194ed5dc8deecf1d380da4f80e0fad2542b9a7ee68d8baca2bc2bfd84fa0459eb3cd18faaf998eb0956fcfb62dc5c8
diff --git a/app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild b/app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild
new file mode 100644
index 000000000000..8dc25fd9b6bd
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-3.2_pre20180106.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp autotools
+
+MY_P="${P%_pre*}"
+DESCRIPTION="The Insidious Big Brother Database"
+HOMEPAGE="https://savannah.nongnu.org/projects/bbdb/"
+#SRC_URI="https://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+SRC_URI="https://git.savannah.nongnu.org/cgit/bbdb.git/snapshot/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+ GPL-1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="tex vm"
+RESTRICT="test" #631700
+
+BDEPEND="vm? ( app-emacs/vm )"
+RDEPEND="${BDEPEND}
+ tex? ( virtual/latex-base )"
+
+SITEFILE="50${PN}-gentoo-3.2.el"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ "$(use_with vm vm-dir "${EPREFIX}${SITELISP}/vm")"
+}
+
+src_compile() {
+ emake -C lisp
+}
+
+src_install() {
+ emake -C lisp DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use tex; then
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins tex/bbdb.sty
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo-3.2.el b/app-emacs/bbdb/files/50bbdb-gentoo-3.2.el
new file mode 100644
index 000000000000..4bbec687fb81
--- /dev/null
+++ b/app-emacs/bbdb/files/50bbdb-gentoo-3.2.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'bbdb-loaddefs)
+;; t indicates that bbdb.sty is in the regular TeX search path
+(setq bbdb-tex-path t)