summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-17 15:01:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-17 15:22:11 +0200
commit8274576f04850cf82351344edda84526d7300878 (patch)
tree88af656e49ce16ff6da9c39931e929092a0aa062 /app-emacs/cape/cape-0.17.ebuild
parentapp-emacs/doom-modeline: drop old 3.3.2 (diff)
downloadgentoo-8274576f04850cf82351344edda84526d7300878.tar.gz
gentoo-8274576f04850cf82351344edda84526d7300878.tar.bz2
gentoo-8274576f04850cf82351344edda84526d7300878.zip
app-emacs/cape: bump to 0.17
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/cape/cape-0.17.ebuild')
-rw-r--r--app-emacs/cape/cape-0.17.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/cape/cape-0.17.ebuild b/app-emacs/cape/cape-0.17.ebuild
new file mode 100644
index 000000000000..16b63bbdfda8
--- /dev/null
+++ b/app-emacs/cape/cape-0.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}