summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-09-10 12:33:03 +0200
committerUlrich Müller <ulm@gentoo.org>2016-09-10 12:33:03 +0200
commitd2b11e23f4cba1ae034bc778b1a0f23dbe7fa2cf (patch)
treedacd40ec59ee7f7ae15c623128b0fb0168d3c778 /app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
parentapp-admin/conky: Fix build without X11. Bug #592252. (diff)
downloadgentoo-d2b11e23f4cba1ae034bc778b1a0f23dbe7fa2cf.tar.gz
gentoo-d2b11e23f4cba1ae034bc778b1a0f23dbe7fa2cf.tar.bz2
gentoo-d2b11e23f4cba1ae034bc778b1a0f23dbe7fa2cf.zip
app-emacs/csharp-mode: Version bump. New upstream.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild')
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild b/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
new file mode 100644
index 000000000000..3a3494d568ff
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="https://github.com/josteink/csharp-mode"
+SRC_URI="https://github.com/josteink/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} csharp-mode.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org
+}