summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-17 15:17:22 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-17 15:19:09 +0200
commitc8b23dc843f17371df14dc0da7620ff040a80039 (patch)
tree16262c8eb6c4b41605347fc63871483333006161 /app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild
parentapp-emacs/go-mode: Update metadata. (diff)
downloadgentoo-c8b23dc843f17371df14dc0da7620ff040a80039.tar.gz
gentoo-c8b23dc843f17371df14dc0da7620ff040a80039.tar.bz2
gentoo-c8b23dc843f17371df14dc0da7620ff040a80039.zip
app-emacs/csharp-mode: Bump to version 0.9.2.
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild')
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild b/app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild
new file mode 100644
index 000000000000..d2dad1639c13
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="https://github.com/josteink/csharp-mode"
+SRC_URI="https://github.com/josteink/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} csharp-mode.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org
+}