summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-13 07:40:10 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-13 07:40:10 +0200
commitae7c0f50ad14597c94f78624bf27117f979ccc38 (patch)
treeff59d738b3af68b7fef6573b343cb59003186759 /app-emacs/dash/dash-2.17.0.ebuild
parentdev-ruby/slop: add 4.8.1 (diff)
downloadgentoo-ae7c0f50ad14597c94f78624bf27117f979ccc38.tar.gz
gentoo-ae7c0f50ad14597c94f78624bf27117f979ccc38.tar.bz2
gentoo-ae7c0f50ad14597c94f78624bf27117f979ccc38.zip
app-emacs/dash: add 2.17.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-emacs/dash/dash-2.17.0.ebuild')
-rw-r--r--app-emacs/dash/dash-2.17.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/dash/dash-2.17.0.ebuild b/app-emacs/dash/dash-2.17.0.ebuild
new file mode 100644
index 000000000000..62c3a1a1c7f3
--- /dev/null
+++ b/app-emacs/dash/dash-2.17.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A modern list library for Emacs"
+HOMEPAGE="https://github.com/magnars/dash.el"
+SRC_URI="https://github.com/magnars/dash.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="dash.texi"
+DOCS="README.md"
+
+src_test() {
+ ./run-tests.sh || die
+}