summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Gaydov <victor@enise.org>2016-08-09 19:14:26 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-09-09 15:34:39 +0200
commite42fea502aac38af57b6049eb412af9daeacb46b (patch)
treeb69743917c0fa2473192070375c34c70d64637b9 /app-emacs/desktop+/desktop+-0.2.ebuild
parentapp-emacs/f: new package. (diff)
downloadgentoo-e42fea502aac38af57b6049eb412af9daeacb46b.tar.gz
gentoo-e42fea502aac38af57b6049eb412af9daeacb46b.tar.bz2
gentoo-e42fea502aac38af57b6049eb412af9daeacb46b.zip
app-emacs/desktop+: new package.
desktop+ extends desktop by providing more features related to sessions persistance. Gentoo-Bug: https://bugs.gentoo.org/590890 Closes: https://github.com/gentoo/gentoo/pull/2050 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-emacs/desktop+/desktop+-0.2.ebuild')
-rw-r--r--app-emacs/desktop+/desktop+-0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/desktop+/desktop+-0.2.ebuild b/app-emacs/desktop+/desktop+-0.2.ebuild
new file mode 100644
index 000000000000..f16dccf10541
--- /dev/null
+++ b/app-emacs/desktop+/desktop+-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="desktop+ extends standard desktop module"
+HOMEPAGE="https://github.com/ffevotte/desktop-plus"
+SRC_URI="https://github.com/ffevotte/desktop-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/dash app-emacs/f"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/desktop-plus-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}