summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-05 14:11:36 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-05 17:05:06 +0200
commit2976eea33924ceb896f8d6abcf1447b92edaf679 (patch)
treefaa147b24fa27e38d75df7428a96183c93bca969 /app-emacs/distel/distel-4.1.1.ebuild
parentmedia-libs/libogg: Bump to version 1.3.4 (diff)
downloadgentoo-2976eea33924ceb896f8d6abcf1447b92edaf679.tar.gz
gentoo-2976eea33924ceb896f8d6abcf1447b92edaf679.tar.bz2
gentoo-2976eea33924ceb896f8d6abcf1447b92edaf679.zip
app-emacs/distel: Bump to version 4.1.1.
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/distel/distel-4.1.1.ebuild')
-rw-r--r--app-emacs/distel/distel-4.1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/distel/distel-4.1.1.ebuild b/app-emacs/distel/distel-4.1.1.ebuild
new file mode 100644
index 000000000000..bfe7b568b6c5
--- /dev/null
+++ b/app-emacs/distel/distel-4.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Distributed Emacs Lisp for Erlang"
+HOMEPAGE="https://massemanet.github.io/distel/
+ https://www.emacswiki.org/emacs/DistributedEmacsLisp"
+SRC_URI="https://github.com/massemanet/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# "New BSD License" according to https://code.google.com/p/distel/
+# "MIT" according to https://github.com/massemanet/distel
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/erlang-11.2.5[emacs]"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake base info
+ cd elisp || die
+ elisp-compile *.el
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ ELISP_DIR="${ED}${SITELISP}/${PN}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/distel.info
+ dodoc AUTHORS ChangeLog NEWS README*
+ use doc && dodoc doc/gorrie02distel.pdf
+ docinto html
+ dodoc doc/distel/*.html
+}