summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Turner <jturner.usa+gentoo@gmail.com>2021-10-17 15:05:09 -0400
committerSam James <sam@gentoo.org>2021-10-20 01:14:14 +0000
commit1231e9f1fde930f55991739d6121af12d136a576 (patch)
treea9dcbdfac2684a391a54696c2f47f172fce074bf /app-emacs/eglot
parentmedia-libs/netpbm: drop v10.86.22 (diff)
downloadgentoo-1231e9f1fde930f55991739d6121af12d136a576.tar.gz
gentoo-1231e9f1fde930f55991739d6121af12d136a576.tar.bz2
gentoo-1231e9f1fde930f55991739d6121af12d136a576.zip
app-emacs/eglot: initial import
Signed-off-by: John Turner <jturner.usa+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22615 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs/eglot')
-rw-r--r--app-emacs/eglot/Manifest1
-rw-r--r--app-emacs/eglot/eglot-1.6.ebuild28
-rw-r--r--app-emacs/eglot/files/50eglot-gentoo.el2
-rw-r--r--app-emacs/eglot/metadata.xml16
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/eglot/Manifest b/app-emacs/eglot/Manifest
new file mode 100644
index 000000000000..1c18d5f83751
--- /dev/null
+++ b/app-emacs/eglot/Manifest
@@ -0,0 +1 @@
+DIST eglot-1.6.tar.gz 288078 BLAKE2B a2214d216d0eeaca32d974c6686696dfcf141b3384741bc8cce0d02abb508eb5713933bc227d12a07f4b87fc34601431845b1b8e519538ae04ecc74b24db4004 SHA512 51227c8e2b0a1dd9a63ededbea592f01616ff728c34c330400c078212fef3f3e747e6dd30ba312523cbe60c7ea663a7af9d83300210cf331ea6162d2db5c7e41
diff --git a/app-emacs/eglot/eglot-1.6.ebuild b/app-emacs/eglot/eglot-1.6.ebuild
new file mode 100644
index 000000000000..913bb955411f
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="26.1"
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client"
+HOMEPAGE="https://github.com/joaotavora/eglot"
+SRC_URI="https://github.com/joaotavora/eglot/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# test requires internet connection to install several language servers, one of which
+# is not packaged
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_REMOVE="eglot-tests.el"
+DOCS=( README.md NEWS.md )
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}
diff --git a/app-emacs/eglot/files/50eglot-gentoo.el b/app-emacs/eglot/files/50eglot-gentoo.el
new file mode 100644
index 000000000000..b8a7e2b65eed
--- /dev/null
+++ b/app-emacs/eglot/files/50eglot-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/eglot-autoload.el")
diff --git a/app-emacs/eglot/metadata.xml b/app-emacs/eglot/metadata.xml
new file mode 100644
index 000000000000..4d327b888ffc
--- /dev/null
+++ b/app-emacs/eglot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jturner.usa+gentoo@gmail.com</email>
+ <name>John Turner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">joaotavora/eglot</remote-id>
+ <doc>https://github.com/joaotavora/eglot/blob/master/README.md</doc>
+ </upstream>
+</pkgmetadata>