summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-28 02:16:39 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-03-28 02:50:50 +0200
commit9b8314c753bde9d11523277af7223061718040a9 (patch)
treeafcc16bb2d903583a21fc03535c75aa51f614e28 /app-emacs/elpher
parentapp-emacs/elpher: drop old 3.4.1 (diff)
downloadgentoo-9b8314c753bde9d11523277af7223061718040a9.tar.gz
gentoo-9b8314c753bde9d11523277af7223061718040a9.tar.bz2
gentoo-9b8314c753bde9d11523277af7223061718040a9.zip
app-emacs/elpher: support live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/elpher')
-rw-r--r--app-emacs/elpher/elpher-3.4.2.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/app-emacs/elpher/elpher-3.4.2.ebuild b/app-emacs/elpher/elpher-3.4.2.ebuild
index 48c35ad2cc84..2b588b300012 100644
--- a/app-emacs/elpher/elpher-3.4.2.ebuild
+++ b/app-emacs/elpher/elpher-3.4.2.ebuild
@@ -3,22 +3,33 @@
EAPI=8
-[[ ${PV} == 3.4.2 ]] && COMMIT=f117f2f
NEED_EMACS=27.1
inherit elisp
DESCRIPTION="Practical and friendly Gopher and Gemini client for GNU Emacs"
HOMEPAGE="https://thelambdalab.xyz/elpher/"
-SRC_URI="https://thelambdalab.xyz/gitweb/index.cgi?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COMMIT}
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://thelambdalab.xyz/${PN}.git"
+else
+ if [[ ${PV} == 3.4.2 ]] ; then
+ COMMIT=f117f2f
+ SRC_URI="https://thelambdalab.xyz/gitweb/index.cgi?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ die "could not generate SRC_URI"
+ fi
+ KEYWORDS="amd64 x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="amd64 x86"
SLOT="0"
-DOCS=( ISSUES.org README )
ELISP_REMOVE="elpher-pkg.el"
+
+DOCS=( ISSUES.org README )
ELISP_TEXINFO="${PN}.texi"
SITEFILE="50${PN}-gentoo.el"