summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-05-06 15:19:25 +0200
committerUlrich Müller <ulm@gentoo.org>2016-05-06 15:19:39 +0200
commit654863a00e893f2e060adfdc8fbecd37c6e93349 (patch)
tree82744d839a9e81772acc5bdb6dc502ca709d0683 /app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
parentapp-text/po4a: revbump to vn. 0.45-r3 (diff)
downloadgentoo-654863a00e893f2e060adfdc8fbecd37c6e93349.tar.gz
gentoo-654863a00e893f2e060adfdc8fbecd37c6e93349.tar.bz2
gentoo-654863a00e893f2e060adfdc8fbecd37c6e93349.zip
app-emacs/emacs-daemon: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild')
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
new file mode 100644
index 000000000000..0374115cf6c2
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <https://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}