summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-09 01:00:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-09 01:02:55 +0200
commit3e5eb7e262631bc0b1a81b072f52a3696ce2f8ec (patch)
tree25bf39c33716f37b8ab588de6068698092352446 /app-emacs/emacs-openrc
parentmedia-gfx/exif: Security fix for CVE-2021-27815 (diff)
downloadgentoo-3e5eb7e262631bc0b1a81b072f52a3696ce2f8ec.tar.gz
gentoo-3e5eb7e262631bc0b1a81b072f52a3696ce2f8ec.tar.bz2
gentoo-3e5eb7e262631bc0b1a81b072f52a3696ce2f8ec.zip
app-emacs/emacs-openrc: new package; add version 0.0.0 & live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emacs-openrc')
-rw-r--r--app-emacs/emacs-openrc/Manifest1
-rw-r--r--app-emacs/emacs-openrc/emacs-openrc-0.0.0.ebuild29
-rw-r--r--app-emacs/emacs-openrc/emacs-openrc-9999.ebuild29
-rw-r--r--app-emacs/emacs-openrc/files/50emacs-openrc-gentoo.el2
-rw-r--r--app-emacs/emacs-openrc/metadata.xml15
5 files changed, 76 insertions, 0 deletions
diff --git a/app-emacs/emacs-openrc/Manifest b/app-emacs/emacs-openrc/Manifest
new file mode 100644
index 000000000000..a35bcaf116b0
--- /dev/null
+++ b/app-emacs/emacs-openrc/Manifest
@@ -0,0 +1 @@
+DIST emacs-openrc-0.0.0.tar.gz 3453 BLAKE2B eadd1ca5f338263e3d7b5c562c7ba1afd8c68dd0a9dc7c682c7b9f8148cbeecb2d8de6c621c5a63262fdcee173bf001ea56a13e40224ece9c9627b2fa84f8bc9 SHA512 04723bb9f087b5da6cea46898af78c6308bebb9f1fc6ee872d9b054bbaafdcb9afaded4f31b318b2f8558e0831243d0006c923e33653fb418c35569112f1bbb0
diff --git a/app-emacs/emacs-openrc/emacs-openrc-0.0.0.ebuild b/app-emacs/emacs-openrc/emacs-openrc-0.0.0.ebuild
new file mode 100644
index 000000000000..f312b46f306e
--- /dev/null
+++ b/app-emacs/emacs-openrc/emacs-openrc-0.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="OpenRC integration for GNU Emacs"
+HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-openrc.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/emacs-openrc/emacs-openrc-9999.ebuild b/app-emacs/emacs-openrc/emacs-openrc-9999.ebuild
new file mode 100644
index 000000000000..f312b46f306e
--- /dev/null
+++ b/app-emacs/emacs-openrc/emacs-openrc-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="OpenRC integration for GNU Emacs"
+HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-openrc.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/emacs-openrc/files/50emacs-openrc-gentoo.el b/app-emacs/emacs-openrc/files/50emacs-openrc-gentoo.el
new file mode 100644
index 000000000000..9118d373d849
--- /dev/null
+++ b/app-emacs/emacs-openrc/files/50emacs-openrc-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "emacs-openrc-autoloads" nil t)
diff --git a/app-emacs/emacs-openrc/metadata.xml b/app-emacs/emacs-openrc/metadata.xml
new file mode 100644
index 000000000000..22c7b92b1e0e
--- /dev/null
+++ b/app-emacs/emacs-openrc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>