summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/emacs-wiki-blog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/emacs-wiki-blog')
-rw-r--r--app-emacs/emacs-wiki-blog/Manifest1
-rw-r--r--app-emacs/emacs-wiki-blog/emacs-wiki-blog-0.5.ebuild20
-rw-r--r--app-emacs/emacs-wiki-blog/files/0.4-gentoo.patch12
-rw-r--r--app-emacs/emacs-wiki-blog/files/90emacs-wiki-blog-gentoo.el19
-rw-r--r--app-emacs/emacs-wiki-blog/metadata.xml9
5 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/emacs-wiki-blog/Manifest b/app-emacs/emacs-wiki-blog/Manifest
new file mode 100644
index 000000000000..fdc3fded83a4
--- /dev/null
+++ b/app-emacs/emacs-wiki-blog/Manifest
@@ -0,0 +1 @@
+DIST emacs-wiki-blog-0.5.tar.bz2 7108 SHA256 eb74abb9ed29d9fc2706675e9ca85214f1ae3026176b7663cdca8a1e0584a15c SHA512 1f0481f3344b3264d33b2ddf9ff7290ef168743092313a3d9198466f002515906e3c4f8f56ef9375ea7ce77b9fb5620b2f1891d6f8b41772df46f7fd34edcc85 WHIRLPOOL 4a3217ec0b919e5c9bb010742ac2e7e038c53a2de4ffb60a447daad5304fa2bdbfbcc85050679717c7138cecf63f717770714d6c3f58ded7240c04e5779ca1b1
diff --git a/app-emacs/emacs-wiki-blog/emacs-wiki-blog-0.5.ebuild b/app-emacs/emacs-wiki-blog/emacs-wiki-blog-0.5.ebuild
new file mode 100644
index 000000000000..77b5627a2c27
--- /dev/null
+++ b/app-emacs/emacs-wiki-blog/emacs-wiki-blog-0.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+DESCRIPTION="Emacs-Wiki add-on for maintaining a weblog"
+HOMEPAGE="http://www.emacswiki.org/emacs/EmacsWikiBlog"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-emacs/emacs-wiki"
+RDEPEND="${DEPEND}"
+
+ELISP_PATCHES="0.4-gentoo.patch"
+SITEFILE="90${PN}-gentoo.el"
diff --git a/app-emacs/emacs-wiki-blog/files/0.4-gentoo.patch b/app-emacs/emacs-wiki-blog/files/0.4-gentoo.patch
new file mode 100644
index 000000000000..f11b1292ec1c
--- /dev/null
+++ b/app-emacs/emacs-wiki-blog/files/0.4-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur emacs-wiki-blog-0.4.orig/emacs-wiki-blog.el emacs-wiki-blog-0.4/emacs-wiki-blog.el
+--- emacs-wiki-blog-0.4.orig/emacs-wiki-blog.el 2005-02-01 03:56:04.000000000 -0600
++++ emacs-wiki-blog-0.4/emacs-wiki-blog.el 2005-02-01 03:59:02.567905058 -0600
+@@ -42,6 +42,7 @@
+
+
+
++(require 'cl)
+ (require 'emacs-wiki)
+ (require 'calendar)
+
+Only in emacs-wiki-blog-0.4: emacs-wiki-blog.el~
diff --git a/app-emacs/emacs-wiki-blog/files/90emacs-wiki-blog-gentoo.el b/app-emacs/emacs-wiki-blog/files/90emacs-wiki-blog-gentoo.el
new file mode 100644
index 000000000000..9c3b97026ef6
--- /dev/null
+++ b/app-emacs/emacs-wiki-blog/files/90emacs-wiki-blog-gentoo.el
@@ -0,0 +1,19 @@
+
+;;; emacs-wiki-blog site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'emacs-wiki-blog-last-n-entries "emacs-wiki-blog")
+(autoload 'emacs-wiki-blog-generate-calendar "emacs-wiki-blog")
+(autoload 'emacs-wiki-blog-generate-archives "emacs-wiki-blog")
+(autoload 'ewb-publish-rss "emacs-wiki-blog")
+(autoload 'gs-latex-tag "latex2png")
+(autoload 'latex2png "latex2png")
+(autoload 'gs-emacs-wiki-thumbnail-tag "plog")
+
+(eval-after-load "emacs-wiki-colors"
+ '(progn
+ (add-to-list 'emacs-wiki-markup-tags '("latex" t t t gs-latex-tag))
+ (add-to-list 'emacs-wiki-markup-tags
+ '("thumb" t t t gs-emacs-wiki-thumbnail-tag))))
+
+(setq gs-latex2png-scale-factor 2.5)
diff --git a/app-emacs/emacs-wiki-blog/metadata.xml b/app-emacs/emacs-wiki-blog/metadata.xml
new file mode 100644
index 000000000000..03ffb61f731b
--- /dev/null
+++ b/app-emacs/emacs-wiki-blog/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Emacs-wiki-blog is an Emacs Lisp package to maintain online journals,
+ like the way blogger or livejournal does, but much more powerful.
+</longdescription>
+</pkgmetadata>