summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-13 08:47:29 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-13 09:37:19 +0200
commit9298b97ef5ecfc40e4aad867d74fef374029ee29 (patch)
tree37f26288febb381e93b66ae6bc6fd485db608fd7 /app-emacs/epc
parentapp-emacs/ctable: new package; add version 0.1.3 (diff)
downloadgentoo-9298b97ef5ecfc40e4aad867d74fef374029ee29.tar.gz
gentoo-9298b97ef5ecfc40e4aad867d74fef374029ee29.tar.bz2
gentoo-9298b97ef5ecfc40e4aad867d74fef374029ee29.zip
app-emacs/epc: new package; add version 0.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/epc')
-rw-r--r--app-emacs/epc/Manifest1
-rw-r--r--app-emacs/epc/epc-0.1.1.ebuild30
-rw-r--r--app-emacs/epc/files/50epc-gentoo.el1
-rw-r--r--app-emacs/epc/metadata.xml13
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/epc/Manifest b/app-emacs/epc/Manifest
new file mode 100644
index 000000000000..b99f46cd24ca
--- /dev/null
+++ b/app-emacs/epc/Manifest
@@ -0,0 +1 @@
+DIST epc-0.1.1.tar.gz 158462 BLAKE2B afbaa496799ac698af885872ab3409ac0e7b27d1299c0450aec75cad6d213fc4efe5b6c2dc48a383b9b061c457accfea81dd821062a7027b781f005cba67e35e SHA512 c6c6e9c2f241ca275b807a387c4fb6916edb02c390d7bc350388d729e2214d7fe5addb7ea634bebc75aa09e510ab2d141ae6a197b328d1f506ee51660a5b8ddc
diff --git a/app-emacs/epc/epc-0.1.1.ebuild b/app-emacs/epc/epc-0.1.1.ebuild
new file mode 100644
index 000000000000..631dd47f8e71
--- /dev/null
+++ b/app-emacs/epc/epc-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="RPC stack for Emacs Lisp"
+HOMEPAGE="https://github.com/kiwanami/emacs-epc/"
+SRC_URI="https://github.com/kiwanami/emacs-epc/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/ctable
+ app-emacs/deferred
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( readme.md demo img )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l epc.el -l epcs.el -l test-epc.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
diff --git a/app-emacs/epc/files/50epc-gentoo.el b/app-emacs/epc/files/50epc-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/epc/files/50epc-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/epc/metadata.xml b/app-emacs/epc/metadata.xml
new file mode 100644
index 000000000000..582f1c4f32f0
--- /dev/null
+++ b/app-emacs/epc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/kiwanami/emacs-epc/issues/</bugs-to>
+ <remote-id type="github">kiwanami/emacs-epc</remote-id>
+ </upstream>
+</pkgmetadata>