summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 19:25:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 19:27:33 +0200
commit433c80f67990133aaee909338786c24a25b918ef (patch)
treeee3924a4921c6628e352e9915fed95635d00040b /app-emacs/epl
parentapp-emacs/ert-runner: new package; add version 0.8.0 (diff)
downloadgentoo-433c80f67990133aaee909338786c24a25b918ef.tar.gz
gentoo-433c80f67990133aaee909338786c24a25b918ef.tar.bz2
gentoo-433c80f67990133aaee909338786c24a25b918ef.zip
app-emacs/epl: enable tests; bump EAPI to 8; format
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/epl')
-rw-r--r--app-emacs/epl/epl-0.9-r1.ebuild (renamed from app-emacs/epl/epl-0.9.ebuild)19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-emacs/epl/epl-0.9.ebuild b/app-emacs/epl/epl-0.9-r1.ebuild
index 8a13d13e32de..0b280f43e459 100644
--- a/app-emacs/epl/epl-0.9.ebuild
+++ b/app-emacs/epl/epl-0.9-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-NEED_EMACS="24"
+NEED_EMACS=24
inherit elisp
@@ -11,10 +11,17 @@ DESCRIPTION="A convenient high-level API for package.el"
HOMEPAGE="https://github.com/cask/epl"
SRC_URI="https://github.com/cask/epl/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
-RESTRICT="test" # test requires cask and ert-runner which are not packaged
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
-SITEFILE="50epl-gentoo.el"
DOCS=( README.md )
+SITEFILE="50epl-gentoo.el"
+
+src_test() {
+ ert-runner || die
+}