summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-01-31 21:44:09 +0100
committerUlrich Müller <ulm@gentoo.org>2016-02-01 10:48:10 +0100
commitff7760ed28a1f5d574bd069fc3c0d97ad631d9f4 (patch)
tree15cd23b95db8b3424d4aa5ae70808f202098a972 /app-emacs/ess/ess-15.09.2.ebuild
parentapp-misc/beep: add alpha keyword (diff)
downloadgentoo-ff7760ed28a1f5d574bd069fc3c0d97ad631d9f4.tar.gz
gentoo-ff7760ed28a1f5d574bd069fc3c0d97ad631d9f4.tar.bz2
gentoo-ff7760ed28a1f5d574bd069fc3c0d97ad631d9f4.zip
app-emacs/ess: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-emacs/ess/ess-15.09.2.ebuild')
-rw-r--r--app-emacs/ess/ess-15.09.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/ess/ess-15.09.2.ebuild b/app-emacs/ess/ess-15.09.2.ebuild
new file mode 100644
index 000000000000..22b3cd709eeb
--- /dev/null
+++ b/app-emacs/ess/ess-15.09.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+MY_P="${PN}-${PV%.*}-${PV##*.}"
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${MY_P}.tgz"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc doc/ChangeLog ChangeLog-doc
+ newdoc lisp/ChangeLog ChangeLog-lisp
+
+ DOC_CONTENTS="Please see /usr/share/doc/${PF} for the complete
+ documentation. Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+ readme.gentoo_create_doc
+}