summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-03-28 21:33:10 +0200
committerUlrich Müller <ulm@gentoo.org>2021-03-28 21:36:39 +0200
commit820166f26ba367eedd9be1371f3143ba469a1d27 (patch)
treefb41223c11531dd772f8f140c72467c3a57dda41 /app-emacs/filladapt
parentapp-emacs/zenirc: EAPI 7, readme.gentoo-r1 (diff)
downloadgentoo-820166f26ba367eedd9be1371f3143ba469a1d27.tar.gz
gentoo-820166f26ba367eedd9be1371f3143ba469a1d27.tar.bz2
gentoo-820166f26ba367eedd9be1371f3143ba469a1d27.zip
app-emacs/filladapt: Fix byte-compilation with Emacs 27
Port to EAPI 7, readme.gentoo-r1.eclass. Closes: https://bugs.gentoo.org/723246 Closes: https://bugs.gentoo.org/778716 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/filladapt')
-rw-r--r--app-emacs/filladapt/files/filladapt-2.12-backquote.patch11
-rw-r--r--app-emacs/filladapt/filladapt-2.12-r2.ebuild21
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/filladapt/files/filladapt-2.12-backquote.patch b/app-emacs/filladapt/files/filladapt-2.12-backquote.patch
new file mode 100644
index 000000000000..83f5f921e2ed
--- /dev/null
+++ b/app-emacs/filladapt/files/filladapt-2.12-backquote.patch
@@ -0,0 +1,11 @@
+--- a/filladapt.el
++++ b/filladapt.el
+@@ -86,7 +86,7 @@
+ (defmacro defgroup (&rest args)
+ nil)
+ (defmacro defcustom (var value doc &rest args)
+- (` (defvar (, var) (, value) (, doc))))))
++ `(defvar ,var ,value ,doc))))
+
+ (defgroup filladapt nil
+ "Enhanced filling"
diff --git a/app-emacs/filladapt/filladapt-2.12-r2.ebuild b/app-emacs/filladapt/filladapt-2.12-r2.ebuild
new file mode 100644
index 000000000000..8d28c9ab62d4
--- /dev/null
+++ b/app-emacs/filladapt/filladapt-2.12-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Filladapt enhances the behavior of Emacs' fill functions"
+HOMEPAGE="http://www.wonderworks.com/"
+SRC_URI="mirror://gentoo/${P}.el.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=("${FILESDIR}"/${P}-backquote.patch)
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Filladapt is not enabled as a site default. Add the following
+ lines to your ~/.emacs file to enable adaptive fill by default:
+ \n\t(require 'filladapt)
+ \n\t(setq-default filladapt-mode t)"