summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-03 01:32:17 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-03 01:32:17 +0200
commit58fa10e41ccf6da01af36f5f78e2d04512affd0c (patch)
treef9a2d4a0a73f88e1206ec9c24b7cd09d99657df1 /app-emacs/flycheck-guile/flycheck-guile-0.2-r1.ebuild
parentdev-libs/nss: Stabilize 3.68.4 ppc, #849347 (diff)
downloadgentoo-58fa10e41ccf6da01af36f5f78e2d04512affd0c.tar.gz
gentoo-58fa10e41ccf6da01af36f5f78e2d04512affd0c.tar.bz2
gentoo-58fa10e41ccf6da01af36f5f78e2d04512affd0c.zip
app-emacs/flycheck-guile: fix runtime deps
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/flycheck-guile/flycheck-guile-0.2-r1.ebuild')
-rw-r--r--app-emacs/flycheck-guile/flycheck-guile-0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/flycheck-guile/flycheck-guile-0.2-r1.ebuild b/app-emacs/flycheck-guile/flycheck-guile-0.2-r1.ebuild
new file mode 100644
index 000000000000..b131c4eb444a
--- /dev/null
+++ b/app-emacs/flycheck-guile/flycheck-guile-0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Flycheck checker for the GNU Guile Scheme implementation"
+HOMEPAGE="https://github.com/flatwhatson/flycheck-guile/"
+SRC_URI="https://github.com/flatwhatson/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-emacs/flycheck
+ app-emacs/geiser-guile
+"
+RDEPEND="
+ ${BDEPEND}
+ >=dev-scheme/guile-2.0.0
+"
+
+DOCS=( README.md )
+ELISP_REMOVE=".dir-locals.el"
+SITEFILE="50${PN}-gentoo.el"