summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-05 18:28:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-05 18:31:22 +0200
commit6bf89a666978221276a5a840f9286f51182d8ba5 (patch)
tree500e92ad309db6d0fd5707e13fd77ec4e8df5591 /app-emacs/git-modes/git-modes-1.4.0.ebuild
parentsys-fs/ncdu: drop 1.15.1-r1 (diff)
downloadgentoo-6bf89a666978221276a5a840f9286f51182d8ba5.tar.gz
gentoo-6bf89a666978221276a5a840f9286f51182d8ba5.tar.bz2
gentoo-6bf89a666978221276a5a840f9286f51182d8ba5.zip
app-emacs/git-modes: new package; add version 1.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/git-modes/git-modes-1.4.0.ebuild')
-rw-r--r--app-emacs/git-modes/git-modes-1.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/git-modes/git-modes-1.4.0.ebuild b/app-emacs/git-modes/git-modes-1.4.0.ebuild
new file mode 100644
index 000000000000..42d918ba7cc7
--- /dev/null
+++ b/app-emacs/git-modes/git-modes-1.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Emacs major modes for editing Git configuration files"
+HOMEPAGE="https://github.com/magit/git-modes/"
+SRC_URI="https://github.com/magit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}