summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-07 13:11:00 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-07 13:31:35 +0200
commitd84d541747d5005755c4e17313d8eb81655781f9 (patch)
tree9835da6b60327e3e6041a8602176689b539c91ba /app-emacs/helm/helm-3.9.3.ebuild
parentapp-emacs/helm: drop old 3.8.8 (diff)
downloadgentoo-d84d541747d5005755c4e17313d8eb81655781f9.tar.gz
gentoo-d84d541747d5005755c4e17313d8eb81655781f9.tar.bz2
gentoo-d84d541747d5005755c4e17313d8eb81655781f9.zip
app-emacs/helm: bump to 3.9.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm/helm-3.9.3.ebuild')
-rw-r--r--app-emacs/helm/helm-3.9.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.9.3.ebuild b/app-emacs/helm/helm-3.9.3.ebuild
new file mode 100644
index 000000000000..76671b3b26bc
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.8.8-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}