summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-01 16:09:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-01 16:09:47 +0200
commitea00025d5c959514a745e3ed988803b879be4040 (patch)
treefd25eff7f2d22f925df85a51a39d0806121e8711 /app-emacs/helm
parentapp-emacs/sokoban: bump to 1.4.9 (diff)
downloadgentoo-ea00025d5c959514a745e3ed988803b879be4040.tar.gz
gentoo-ea00025d5c959514a745e3ed988803b879be4040.tar.bz2
gentoo-ea00025d5c959514a745e3ed988803b879be4040.zip
app-emacs/helm: bump to 3.8.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/files/helm-3.8.8-no-autoload-check.patch24
-rw-r--r--app-emacs/helm/helm-3.8.8.ebuild37
3 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index 9d7e3fa55c69..bf481af47eea 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,3 +1,4 @@
DIST helm-3.8.5.tar.gz 2349290 BLAKE2B 84f0c15c2a9f492246defdf9496e8dcc5265b0c60b50ccaaa3b9f6731285a667da919da7fec80d77a4fd11bc83d9f4ae4c0910e31423b58afbdf00d51b070295 SHA512 af727553c29c9fa0ba6eb6a73b25d62855ea4413eebc57baf3ed94be6a0240e4c558193c898430dc21132ba5e32ead584514910bf98b3b8d82adf7828f953652
DIST helm-3.8.6.tar.gz 2356253 BLAKE2B 62b9af26888526f54726468e04677c401c5e828e588cb6f2c005b9ce9d84935c184b536a97a82e4e6c08c3523a10a32f9348d243d2545c17c9480ad004d92d10 SHA512 71342f347aa5cf8bd3e1990c8633d908e6a5fe66e051554aa2f554fba5d63b2623fe2b6b07540473b481986b1d5d27cb2d8b06f127e727aa8d373bc045d0a602
DIST helm-3.8.7.tar.gz 2358726 BLAKE2B a76c7c6658997f4d5114e383e1ca728df923b0216c66c9d4c2f9d1d656d06990299ebc79f4ad9c50da1dd133f8111c947e6f238324fbe91c5af5a1ab02aa1c7f SHA512 d7356e407d1ef463e62e7d0f2c3b0f90d150744fa020638740226a3e04e043be0e551effd2c17cd2e8c0d82d70351cb5268a89eca2c9ef6355fcce65a445f9bc
+DIST helm-3.8.8.tar.gz 2362007 BLAKE2B 80f854bc38e51de62aa6d9a35cdeff4ac4c193908dc19361ad10ad419585d30a2fd94be1d4d410b69634012e4c01045d4dd2f55c5b4ac8da960d7f7b8d4eed08 SHA512 a1fca373d2c64771aabb3ba396e0d65b3434f0a413bab1e61761c16e9dcf274ceb94e258ef90f4ddd2b150a09606255ea61186d2e4e69ad2600fc40369c693c7
diff --git a/app-emacs/helm/files/helm-3.8.8-no-autoload-check.patch b/app-emacs/helm/files/helm-3.8.8-no-autoload-check.patch
new file mode 100644
index 000000000000..01ef1a169686
--- /dev/null
+++ b/app-emacs/helm/files/helm-3.8.8-no-autoload-check.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/800177
+
+--- a/emacs-helm.sh
++++ b/emacs-helm.sh
+@@ -137,19 +137,6 @@ LOAD_PATH=$($EMACS -q -batch --eval "(prin1 load-path)")
+
+ cd "${0%/*}" || exit 1
+
+-# Check if autoload file exists.
+-# It may be in a different directory if emacs-helm.sh is a symlink.
+-TRUENAME=$(find "${0%/*}" -path "$0" -printf "%l")
+-if [ -n "$TRUENAME" ]; then
+- AUTO_FILE="${TRUENAME%/*}/helm-autoloads.el"
+-else
+- AUTO_FILE="helm-autoloads.el"
+-fi
+-if [ ! -e "$AUTO_FILE" ]; then
+- echo No autoloads found, please run make first to generate autoload file
+- exit 1
+-fi
+-
+
+ cat > $CONF_FILE <<EOF
+ (setq initial-scratch-message (concat initial-scratch-message
diff --git a/app-emacs/helm/helm-3.8.8.ebuild b/app-emacs/helm/helm-3.8.8.ebuild
new file mode 100644
index 000000000000..a99c12c1de3c
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}