summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-20 16:23:14 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-20 16:23:14 +0200
commit8ea06ecc4cdffc801330ae7c1eeb38b821b44ffa (patch)
treeb13edbfbfc3a69e39bd3b19c75fe028749756b68 /app-emacs/ht
parentdev-python/zope-interface: Stabilize 5.4.0-r1 x86, #839708 (diff)
downloadgentoo-8ea06ecc4cdffc801330ae7c1eeb38b821b44ffa.tar.gz
gentoo-8ea06ecc4cdffc801330ae7c1eeb38b821b44ffa.tar.bz2
gentoo-8ea06ecc4cdffc801330ae7c1eeb38b821b44ffa.zip
app-emacs/ht: enable tests
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ht')
-rw-r--r--app-emacs/ht/ht-2.3.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/app-emacs/ht/ht-2.3.ebuild b/app-emacs/ht/ht-2.3.ebuild
index 2b56bec9cad3..aac3d564cceb 100644
--- a/app-emacs/ht/ht-2.3.ebuild
+++ b/app-emacs/ht/ht-2.3.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit elisp
-IUSE=""
-
DESCRIPTION="The missing hash table library for Emacs"
HOMEPAGE="https://github.com/Wilfred/ht.el"
SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ht.el-${PV}"
+
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
-DOCS="CHANGELOG.md README.md"
-
-SITEFILE="50${PN}-gentoo.el"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=app-emacs/dash-2.12.0
"
-DEPEND=${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/f
+ app-emacs/ert-runner
+ )
+"
-S="${WORKDIR}/ht.el-${PV}"
+DOCS="CHANGELOG.md README.md"
+SITEFILE="50${PN}-gentoo.el"
-# Requires unpackaged dependencies, e.g. Cask
-RESTRICT="test"
+src_test() {
+ ert-runner --reporter ert+duration --script || die
+}