summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-30 21:40:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-31 00:09:27 +0100
commit10baa53465676e7e0afba90c4915bfc408a1a3d2 (patch)
tree30beef5c1d1e17449008f47b1e58ef85a2d34d91 /app-emacs/mastodon/mastodon-1.0.19.ebuild
parentapp-emacs/mastodon: support live (diff)
downloadgentoo-10baa53465676e7e0afba90c4915bfc408a1a3d2.tar.gz
gentoo-10baa53465676e7e0afba90c4915bfc408a1a3d2.tar.bz2
gentoo-10baa53465676e7e0afba90c4915bfc408a1a3d2.zip
app-emacs/mastodon: bump to 1.0.19
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/mastodon/mastodon-1.0.19.ebuild')
-rw-r--r--app-emacs/mastodon/mastodon-1.0.19.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/mastodon/mastodon-1.0.19.ebuild b/app-emacs/mastodon/mastodon-1.0.19.ebuild
new file mode 100644
index 000000000000..38f5552d3c9f
--- /dev/null
+++ b/app-emacs/mastodon/mastodon-1.0.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client for Mastodon, federated microblogging social network"
+HOMEPAGE="https://codeberg.org/martianh/mastodon.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/martianh/mastodon.el.git"
+else
+ SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el/lisp"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/persist
+ app-emacs/request
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( ../README.org )
+ELISP_TEXINFO="../${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"