summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-05 11:20:38 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-05 11:30:38 +0100
commitc3a6ed56b01d7aaeca3cce20f30872f710f9202b (patch)
tree50aaa13c4e07ed3c5e5fa104052234302a8d7f89 /app-emacs/mpg123-el/mpg123-el-1.60.ebuild
parentapp-emacs/mpg123-el: Drop vorbis flag. (diff)
downloadgentoo-c3a6ed56b01d7aaeca3cce20f30872f710f9202b.tar.gz
gentoo-c3a6ed56b01d7aaeca3cce20f30872f710f9202b.tar.bz2
gentoo-c3a6ed56b01d7aaeca3cce20f30872f710f9202b.zip
app-emacs/mpg123-el: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emacs/mpg123-el/mpg123-el-1.60.ebuild')
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.60.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/mpg123-el/mpg123-el-1.60.ebuild b/app-emacs/mpg123-el/mpg123-el-1.60.ebuild
new file mode 100644
index 000000000000..8514362a9be8
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.60.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="mpg123-el"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-sound/mpg123
+ media-sound/alsa-utils"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el
+}
+
+src_install() {
+ dobin tagput id3put
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}