summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:12:32 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:54 +0100
commit07a244ded9ac8db7e25a1dad982f4baa308e93e4 (patch)
tree480609ce17d11fab1b0967698c7e1dc8a76c10b0 /app-emacs/osm/osm-1.3.ebuild
parentapp-emacs/osm: drop old 0.14 (diff)
downloadgentoo-07a244ded9ac8db7e25a1dad982f4baa308e93e4.tar.gz
gentoo-07a244ded9ac8db7e25a1dad982f4baa308e93e4.tar.bz2
gentoo-07a244ded9ac8db7e25a1dad982f4baa308e93e4.zip
app-emacs/osm: bump to 1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/osm/osm-1.3.ebuild')
-rw-r--r--app-emacs/osm/osm-1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/osm/osm-1.3.ebuild b/app-emacs/osm/osm-1.3.ebuild
new file mode 100644
index 000000000000..0c1baa6015e8
--- /dev/null
+++ b/app-emacs/osm/osm-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}:*[jpeg,json,libxml2,png,svg]
+ >=app-emacs/compat-29.1.4.0
+"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}