summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-04 16:43:09 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-04 16:43:09 +0200
commitf98fd69b5cccdd9cdfc508ba6ae4a005e676bc68 (patch)
tree3f32d694fb6da1317dd8b3bc169a90177371ed8a /app-emacs/parsebib
parentsci-chemistry/gromacs: Update 9999 (diff)
downloadgentoo-f98fd69b5cccdd9cdfc508ba6ae4a005e676bc68.tar.gz
gentoo-f98fd69b5cccdd9cdfc508ba6ae4a005e676bc68.tar.bz2
gentoo-f98fd69b5cccdd9cdfc508ba6ae4a005e676bc68.zip
app-emacs/parsebib: bump to 4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/parsebib')
-rw-r--r--app-emacs/parsebib/Manifest1
-rw-r--r--app-emacs/parsebib/parsebib-4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/parsebib/Manifest b/app-emacs/parsebib/Manifest
index 36cc33b12a9d..05cd17e64f74 100644
--- a/app-emacs/parsebib/Manifest
+++ b/app-emacs/parsebib/Manifest
@@ -1 +1,2 @@
DIST parsebib-3.1.tar.gz 19298 BLAKE2B 1588a9ef6e1642a612be2abb340d9127f8b8542ac2edda0deb5d9be28903443a33de877e44cefceba110332c022b8e4885a2927f172a447f035e9a5c0e65b5a5 SHA512 10dc25831693d271582b2d561401399e12ac3ccbc994dc95ae22fec800e1b242461deaa6a1c0ae5b20a1834baf88017b3ee42f1a53ac5d73f73a2f69c050c6c2
+DIST parsebib-4.1.tar.gz 24384 BLAKE2B 4546b49ea49a890b7a640cbbf1103500e6e1d3628d990c1c24c4943024b51f5293919315ab82134cb823799ac8d04e5c174671db3379c9a0a9cf7aa02bb8c36c SHA512 37df3265b51e0a1d2b418f2a862691300c369bcee01beec19abe4ebd160c4a279427f7a4b012828ca5b39f0c2064660c3ed73edfef400f543a9157761aabbbb3
diff --git a/app-emacs/parsebib/parsebib-4.1.ebuild b/app-emacs/parsebib/parsebib-4.1.ebuild
new file mode 100644
index 000000000000..6d23c9db04f0
--- /dev/null
+++ b/app-emacs/parsebib/parsebib-4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp library for reading .bib files"
+HOMEPAGE="https://github.com/joostkremers/parsebib/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}