summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-06 00:32:25 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-06 00:34:13 +0100
commit1736428543ffc009edcecbd4e41d2c56e4d18d3e (patch)
tree3062cdb402f272c46d5db35a442b51e12a1029a0 /app-emacs/python-mode
parentapp-text/zathura-cb: Remove optional decompressors from RDEPEND (bug 608284). (diff)
downloadgentoo-1736428543ffc009edcecbd4e41d2c56e4d18d3e.tar.gz
gentoo-1736428543ffc009edcecbd4e41d2c56e4d18d3e.tar.bz2
gentoo-1736428543ffc009edcecbd4e41d2c56e4d18d3e.zip
app-emacs/python-mode: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/Manifest1
-rw-r--r--app-emacs/python-mode/python-mode-6.2.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
index 01d5052d7c20..0dd0ec46e571 100644
--- a/app-emacs/python-mode/Manifest
+++ b/app-emacs/python-mode/Manifest
@@ -3,3 +3,4 @@ DIST python-mode.el-6.0.12.tar.gz 297981 SHA256 85a1ae9b8514330613887ef2cd305cef
DIST python-mode.el-6.1.1.tar.gz 313595 SHA256 3eea9722d8407024dcad38b26029992333b357009c9f0d755e2ef7ac06c55a85 SHA512 66226db207421cd33812505e74b986b279534876386fa1b2bc90d58fb35cacfb9fd2790a3dd760becd2797a390d0960035f2ee0d5636c83daf6d0c699d122609 WHIRLPOOL a020e7ce9ceccb8e8d34e88e45bcee668462d286463a6b87ce26c14108c6c66b862bcd78ea7a962ff3f6644a6d4c8ffa06e290eff2a8fb828a21d5f45b44f441
DIST python-mode.el-6.1.2.tar.gz 330107 SHA256 ae1223bba504c6db08b7a4fc5ef2e148ad861048b4146f5966ddb4ce39e244e3 SHA512 967ad7fdb3503c2dc37df79ba9f45ed7627a5b8e287cae9e8963a259a6568282c16d509e873c7d8b97e4acaafbd71dcec00e5ac71ed695b20ecddca5da20ba96 WHIRLPOOL 05a9f6f60fa0dca16695c1b9fd43fe5c9d9304cc564292412df12d1894f971c119b0d4a57c297684968e58e0bb4a5e9f4472700d7d9fff461f20294c4c5faabe
DIST python-mode.el-6.2.0.tar.gz 393046 SHA256 3238df550a4dec1523efbbba6090e3bb6cb9d4d31973b8a9a4852d6640a0e8a9 SHA512 0280649fa646e071a756a657be91dc3b4ab0a227105eeba7601b98fbac1916af0607add20c58c74434eb2fa139a996736e963783b1500ca6f3656a90deaa427e WHIRLPOOL ed829a8f3c1ca1f1f06ef7aa562fa74bb31f202b067a309c341f257aa609f15d767473fdbd6279776422a0660bf339aee4583ecae1df7439e41d61ad4764fcf0
+DIST python-mode.el-6.2.3.tar.gz 314461 SHA256 40098432ca1b3e3dcd8fa0a7d23bd8f2e57471587911d448b9c5cde0569d3335 SHA512 4aeb33d4054d582cd2a3f4834472c7d0cb3fe5e12e10f5117dcbcd90ec2ca490964c774918c83697f283c68e57766c3c67d3853ddbaa3408777fdafc7f2674f2 WHIRLPOOL ec36db8a39ee8e5722a05ddc333ea8bc36479cdae623ea821cfbc0f2b89d628f96a5bc8b66044d4a183eda21c18a157e78ba0f8899d11405e558ac3b21f09437
diff --git a/app-emacs/python-mode/python-mode-6.2.3.ebuild b/app-emacs/python-mode/python-mode-6.2.3.ebuild
new file mode 100644
index 000000000000..29e6f19f65ac
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README_DEVEL.org"
+DOC_CONTENTS="Note that doctest and pymacs are in their own packages,
+ app-emacs/doctest-mode and app-emacs/pymacs, respectively."