summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/rudel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/rudel')
-rw-r--r--app-emacs/rudel/Manifest1
-rw-r--r--app-emacs/rudel/files/60rudel-gentoo.el13
-rw-r--r--app-emacs/rudel/metadata.xml13
-rw-r--r--app-emacs/rudel/rudel-0.3_pre20110721.ebuild48
4 files changed, 75 insertions, 0 deletions
diff --git a/app-emacs/rudel/Manifest b/app-emacs/rudel/Manifest
new file mode 100644
index 000000000000..02d61da43c98
--- /dev/null
+++ b/app-emacs/rudel/Manifest
@@ -0,0 +1 @@
+DIST rudel-0.3_pre20110721.tar.xz 416060 SHA256 7c0a3ba5ff7d8c5bfdb7a53c1d2d138977e2795025388a1b5fdaf0f031e6b2af SHA512 abf6c8eb4fcaf4acafb9bed7cafff5d3c8e19e3fecd2aa779065bfb11ce5cb198ef14cc9deed360ac895166ea159a821e24dc92dbeda4f5481d1bb3bc2f8c023 WHIRLPOOL 5160716cd66ab4c4df18e8f02a31807ae9e6f239d532ddc1837a3d34c548ae5abd349ba86abc3b9613f44d5a7450d82837b18f5fbca7eaa52b617a1345c4d626
diff --git a/app-emacs/rudel/files/60rudel-gentoo.el b/app-emacs/rudel/files/60rudel-gentoo.el
new file mode 100644
index 000000000000..2383074cfe17
--- /dev/null
+++ b/app-emacs/rudel/files/60rudel-gentoo.el
@@ -0,0 +1,13 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rudel-join-session "rudel-loaddefs"
+ "Start a collaborative Rudel session" t)
+(autoload 'rudel-host-session "rudel-loaddefs"
+ "Host a collaborative Rudel session" t)
+(autoload 'rudel-speedbar "rudel-loaddefs"
+ "Show connected users and documents for the Rudel session in speedbar" t)
+(autoload 'global-rudel-minor-mode "rudel-loaddefs"
+ "Bindings for rudel session-level commands" t)
+
+;;(global-set-key (kbd "C-c c j") 'rudel-join-session)
+
+(setq rudel-icons-directory "@SITEETC@/icons/")
diff --git a/app-emacs/rudel/metadata.xml b/app-emacs/rudel/metadata.xml
new file mode 100644
index 000000000000..8a0c53e6c406
--- /dev/null
+++ b/app-emacs/rudel/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Rudel is collaborative editing environment for GNU Emacs. Its purpose
+ is tod share buffers with other users in order to edit the contents
+ of those buffers collaboratively. Rudel supports multiple backends to
+ enable communication with other collaborative editors using different
+ protocols, though currently Obby (for use with the Gobby editor) is
+ the only fully-functional one.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/rudel/rudel-0.3_pre20110721.ebuild b/app-emacs/rudel/rudel-0.3_pre20110721.ebuild
new file mode 100644
index 000000000000..71ef62d767a4
--- /dev/null
+++ b/app-emacs/rudel/rudel-0.3_pre20110721.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Collaborative editing environment for GNU Emacs"
+HOMEPAGE="http://rudel.sourceforge.net/
+ http://www.emacswiki.org/emacs/Rudel"
+# snapshot of bzr://rudel.bzr.sourceforge.net/bzrroot/rudel/trunk
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} -l rudel-compile.el || die
+}
+
+src_install() {
+ local dir
+
+ for dir in . adopted infinote jupiter obby socket telepathy tls \
+ xmpp zeroconf
+ do
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins ${dir}/*.{el,elc}
+ done
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+
+ dodoc README INSTALL ChangeLog TODO doc/card.pdf
+
+ DOC_CONTENTS="Connections to Gobby servers require the gnutls-cli program
+ (net-libs/gnutls).
+ \\n\\nThe Avahi daemon (net-dns/avahi) is required for automatic
+ session discovery and advertising."
+ readme.gentoo_create_doc
+}