summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 21:27:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 22:40:09 +0200
commit2c45d9c924a90b491540df6e809bbc75d62e71c2 (patch)
tree166a2de7584fe88308c3ff3548daa0a0bd9ac0ae /app-emacs/shell-split-string
parentapp-emacs/ert-async: new package; add version 0.1.2_p20200105 (diff)
downloadgentoo-2c45d9c924a90b491540df6e809bbc75d62e71c2.tar.gz
gentoo-2c45d9c924a90b491540df6e809bbc75d62e71c2.tar.bz2
gentoo-2c45d9c924a90b491540df6e809bbc75d62e71c2.zip
app-emacs/shell-split-string: new package; add version 0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/shell-split-string')
-rw-r--r--app-emacs/shell-split-string/Manifest1
-rw-r--r--app-emacs/shell-split-string/files/50shell-split-string-gentoo.el1
-rw-r--r--app-emacs/shell-split-string/metadata.xml13
-rw-r--r--app-emacs/shell-split-string/shell-split-string-0.1.ebuild22
4 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/shell-split-string/Manifest b/app-emacs/shell-split-string/Manifest
new file mode 100644
index 000000000000..cd0fd64bb78c
--- /dev/null
+++ b/app-emacs/shell-split-string/Manifest
@@ -0,0 +1 @@
+DIST shell-split-string-0.1.tar.gz 3453 BLAKE2B 3907501aff6aeee821050980b0c65612e0b76bfc3dc98735d70b2bdabd4bd19d1225d4e5c85bc2910e795e53715d2dfc49b900c24f8ed6bb63751e8e25e41c89 SHA512 55b76a4664cecb1c894559efd8270a567868f1e758b55ea23480cfdb550009af0042d69302b7ac7b73eef54e01c01e9978bfb5421d2db3806a4054e3b7e8f893
diff --git a/app-emacs/shell-split-string/files/50shell-split-string-gentoo.el b/app-emacs/shell-split-string/files/50shell-split-string-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/shell-split-string/files/50shell-split-string-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/shell-split-string/metadata.xml b/app-emacs/shell-split-string/metadata.xml
new file mode 100644
index 000000000000..4f91116c53ca
--- /dev/null
+++ b/app-emacs/shell-split-string/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/10sr/shell-split-string-el/issues/</bugs-to>
+ <remote-id type="github">10sr/shell-split-string-el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shell-split-string/shell-split-string-0.1.ebuild b/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
new file mode 100644
index 000000000000..1538d8985c5d
--- /dev/null
+++ b/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Split Strings Using Shell-Like Syntax"
+HOMEPAGE="https://github.com/10sr/shell-split-string-el/"
+SRC_URI="https://github.com/10sr/${PN}-el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-el-${PV}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake emacs=${EMACS} test
+}